Problemas con PPPoE



  • Hola tengo dos server con la wan en dhcp y los routers en modo PPPoE y funcionan bien, si pongo el router en modo bridge y el Pfsense 2.0.1 en modo PPPoE este es capaz de conectar con internet ya que puedo instalar nuevos paquetes pero no tengo internet en la LAN

    Saludos


  • Rebel Alliance

    Se me ocurre, no tendras el gateway antiguo (el que utilizabas cuando tenias el modem como router) como "default" gateway ?

    Tambien revisa los DNS

    Yo utilizo la version 2.0.1 con PPPoE, con el Modem en "Bridge", sin problemas.

    Saludos



  • en verdad no cambio nada, es decir no tengo ni idea como va lo del gateway si me lo pudieras explicar graficamente te lo agradecere.

    no se si te refieres en la opcion del proxy en las rules no tengo ni idea.

    saludos


  • Rebel Alliance

    En: System –> Routing --> Gateways

    Que tienes configurado ?



  • ahora que la wan esta en dhcp client esta:

    WAN (default) WAN 192.168.200.1 192.168.200.1 Interface WAN Dynamic Gateway

    cuando la ponga a PPPoE como debe estar?



  • Con PPPoE aparece como dynamics no creo que sea de eso, aunque antes dije que pfsense si conectaba con internet ahora veo que no es asi
    sin enbargo en la misma red si monto un ipcop con marcado pppoe con el mismo router y todo igual solo que cambio pfsense por ipcop este funciona perfectamente, yo creo que es el marcado del pfsense el que no funciona

    adjunto img

    ![Sin título.png](/public/imported_attachments/1/Sin título.png)
    ![Sin título.png_thumb](/public/imported_attachments/1/Sin título.png_thumb)


  • Rebel Alliance

    Adjunto 6 imagenes que muestran como lo tengo yo en el mio:

    01: en el "Dashboard" fijate que la WAN esté "UP" y con una IP, el GW "Online" y los DNS configurados

    02: En System Gateways deberia quedar algo asi

    03: Revisa la configuracion de DNS  ( generalmente prefiero asignarlos manualmente, y no usar los del ISP )

    04: Revisa la asignacion de Interfaces

    05: Fijate que en la configuracion de PPPoE hay opciones adicionales

    06: En algunos casos hay que configurar "nombre de servicio nulo"

    en las configuraciones vas a ver que la placa ethernet "re0" esta asignada a 2 interfaces ( WAN y GEST ), esto el para poder acceder al menu del Modem: http://doc.pfsense.org/index.php/Accessing_modem_from_inside_firewall

    Espero puedas solucionar tu problema.














  • Gracias ahora lo probare pero es mas o menos como lo tengo, una pregunta porque en el dashboard aparece tu wan como 186 y en gateway como 172 y no aparece la ip publica?


  • Rebel Alliance

    En las conexiones PPPoE el GW puede ser cualquier IP, inclusive puedes tener una IP publica (186.x.x.x ) y el GW puede ser una Privada (172.x.x.x), y la mascara de subred es 255.255.255.255, asi es como trabaja el PPPoE.


Locked