Apache + mod_security on 2.0.1-RELEASE



  • Good Evening,

    has anybody had any problems with running apache2 after upgrading to the 2.0.1-RELEASE of pfsense?

    I recently upgraded, and then found that I cannot restart the webserver. I get the following error:

    /libexec/ld-elf.so.1: Shared object "libcrypt.so.4" not found, required by "libaprutil-1.so.3

    I had this the mod_sec package successfully installed previously and working happily…

    could anybody point me in the right direction to get this working??

    Many thanks,
    Dan



  • I was about to install this, did you get it working?



  • Hi, yes sorta…

    I had this running quite stably for the last 6 months but after the last pfsense upgrade it broke.

    I still havent fixed the problem, but i have moved forward..

    I first thought I had to install the latest openssl package - thinking that that would fix my missing dependancy... To do that i had to get the pkg_add to direct to the correct package site. to do that, i followed the instructions on this site:

    http://forum.pfsense.org/index.php?topic=41582.0

    then i found that the log for apache said there was a problem with it not finding the correct cryptlibrary, so i setup a soft link to correct library:

    http://forums.kayako.com/threads/zendoptimizer-on-freebsd-7-2.21597/

    so thats as far as i got. There is now a new error:

    [warn] (2)No such file or directory: Failed to enable the 'dataready' Accept Filter

    and from what i can find this error means that the filter isnt loaded. I tired 'kldload' and then it gave this error:

    kldload: can't load accf_http.ko: No such file or directory

    and this is bout where im stuck…

    im really out of my depth here so if anybody has any hints??? please let me know

    Cheers,
    Dan



  • Well i dont know if i did this the "correct" way. but its back up and running…

    because the accf_http.ko and accf_data.ko were missing i did a google search for the files. found them (dont know if they were the right ones...) and loaded them with kldload - also changed the /boot/loader.conf to load those two modules at startup.

    once done there was another error about not being able to resolve my hostname. so i added a static entry into my dns server, rebooted and it all worked again...

    so anywho, hope this information helps somebody down the line...

    -Dan



  • I guess the problem is not coming from accf_http, the problem is the missing dataready filter, which is accf_data. To solve this problem,you'll have to update the /boot/loader.conf and add the following into the file:

    accf_data_load="YES"

    here's the solution in more details:
    http://www.techyv.com/questions/error-after-updating-apache-freebsd-box



  • Yes i have seen a similar help topic. The problem was that both accf_http.ko and accf_data.ko were missing so even putting that line in the /boot/loader.conf was not helping.

    That is why i searched and found a copy of those *.ko files. What i dont know is whether they were suitable for my build? is there a better way?



  • @dandantheflyingman:

    Yes i have seen a similar help topic. The problem was that both accf_http.ko and accf_data.ko were missing so even putting that line in the /boot/loader.conf was not helping.

    That is why i searched and found a copy of those *.ko files. What i dont know is whether they were suitable for my build? is there a better way?

    Could you post a link to the files? or upload them. Where did you save them once downloaded?

    I think I am having the same problem.

    Cheers.


Locked