High interrupts?



  • Hi all!

    I configured latest release 2.0.1 pfsense.
    For 2 days it was working just fine, now all of the sudden I have very high interrupts.
    From 34-60%…

    vmstat -i shows:

    interrupt                          total       rate
    irq4: uart0                      7361324      24702
    irq16: fxp0 fxp1                    3558         11
    irq17: fxp2 fxp3                    3287         11
    irq20: atapci0                      3249         10
    irq21: uhci0 uhci1*                   23          0
    cpu0: timer                       593503       1991
    Total                            7964944      26728
    

    Is uart0 the problem here?
    This is serial output right?

    There is almost no traffic on firewall…
    Maybe 10-40 Kbps...

    It was all working fine for 2 days... Today in the morning bam, interrupts were sky high....

    Any idea what should I do?

    Thanks!



  • 24k interrupts per second is a high rate, especially for a serial port. Maybe you can disable the COM ports in the BIOS. Does the COM port have a cable connected? Maybe the cable is picking up noise on the UART Rx line and that is causing interrupts.

    Maybe you could set the UART speed to a much lower value and that should correspondingly reduce the interrupt rate.



  • Hi!

    Thanks for suggestion.

    I only have:

    1. VGA cable connected
    2. 3x LAN conncted (2nics in lagg0 for LAN, one nic for other network)
    3. 1x WAN connected
    4. USB keyboard

    I`m looking at this from remote location…
    Console is not connected...



  • What does @maverick_slo:

    Console is not connected…

    mean? You are using a serial port as the system console but it is not connected?

    Please provide output of pfSense shell command```
    sysctl kern.tty_nout; sleep 60; sysctl kern.tty_nout
    sysctl kern.tty_nin ; sleep 60; sysctl kern.tty_nin

    
    Does the pfSense _top_ command show a high percentage of time in interrupts?


  • Huh…

    I use VGA and keyboard :)
    I should disable Serial port probably since I do not use it...

    
    Out:
    kern.tty_nout: 721880
    kern.tty_nout: 721903
    
    and in:
    
    kern.tty_nin: 459
    kern.tty_nin: 459
    
    
    last pid: 41605;  load averages:  0.78,  0.99,  0.93     up 0+03:04:59  13:49:14
    42 processes:  1 running, 41 sleeping
    CPU:  0.4% user,  0.0% nice,  0.4% system, 58.0% interrupt, 41.3% idle
    Mem: 41M Active, 17M Inact, 42M Wired, 968K Cache, 25M Buf, 866M Free
    Swap: 8192M Total, 8192M Free
    


  • @maverick_slo:

    
    Out:
    kern.tty_nout: 721880
    kern.tty_nout: 721903
    
    and in:
    
    kern.tty_nin: 459
    kern.tty_nin: 459
    
    

    Lots of uart interrupts that aren't accompanied by tty input characters or output characters uggests to me a noisy uart Rx line.

    @maverick_slo:

    I should disable Serial port probably since I do not use it…

    I think so.



  • So basically this should resolve this issue right?

    But still… Console port is not plugged anywhere... Strange that this started to happen today...



  • Yeah, I disabled console and all com ports, now it`s working great…

    Thanks for support!


Locked