Pppoe is just not working for me, regardless of my efforts



  • I have read every post in the forum and tried every suggestion, I am getting nowhere with pppoe over the wan. I have no problem with monowall, btw.

    Here is what I have done using PFsense 2.01 installed to hard drive with both a clean install and an import of settings from monowall:

    • setup wizard > connects and gets the IP, can ping out all day long, can access google services (which already have an open connection) but cannot load any other pages… again, ping OK, DNS resolve OK, access the page no joy

    • add pppoe in the ppp section, assign to an interface > cannot connect to dsl modem = no joy

    • setup pppoe by selecting the wan interface and choosing pppoe and filling the relavent info > behaviour same as the wizard = no joy

    • tried NULL service name both ways > no joy

    • tried a bridge based on one obscure post > no joy and it didn't make any sense anyware

    • played with advanced settings and MTU settings > no joy

    • rebooted after several of the iterations > no joy

    • tried removing all interfaces before each step > no joy

    • restarted the modem on each iteration > no joy

    • rinse & repeat > no joy

    The only interesting error I get in the logs is that the gateway of the modem (this is the auto-assigned gateway I get from the modem, not a gateway configured in PFSense) will get the following error continuously in the system log: "kernel arpresolve can't allocate llinfo for 209.193.63.151" it is continous in the log. The strange thing is that after a few minutes things like skype start working, I can even google search and anything cached in google I can read. I can also load some pages, and others just spin like they are loading forever.

    I am at a loss. I would really appreciate some help. I had planned on moving all my monowall routers to pfsense 2x, but I have a couple that are pppoe and I am afraid of what the result will be, and I don't want a mixed environment if I have any choice about it.

    (edit) I forgot to mention the hardware. I am doing an HDD install. I have tried it on 3 different systems, all i386, I have used 6 different NICs (internal and external). All of them have a minimum p4 2ghz with 1gig of ram.

    _____  ____    
    /___ /\  `\  
    /
    /\ \ \ _\
      \ \ \ \ ,
    /
     /\ _\ \ \ /
     \ _/\ _
      /
    /  /_/



  • What is in the PPP logs on pfSense? (See Status -> System Logs, click on PPP tab) I have just noticed my ppp log is empty. Perhaps your ppp log won't yield any useful information.

    What is the output of the pfSense shell command ifconfig -a

    Have you followed suggestions in http://doc.pfsense.org/index.php/Accessing_modem_from_inside_firewall


Locked