Cannot access my Draytek Vigor 120 DSL Modem



  • I'm stuck and I need a little bit of help!

    Now that I've updated to pfSense v2 (and now updated to v2.01), I now cannot access my Draytek Vigor 120 DSL Modem using the redir package.

    The instructions that I used for pfSense v1.2.3 were nice and simple:

    
    pkg_add -r redir
    rehash
    ifconfig re0 192.168.1.10/24
    redir --lport 8989 --cport 80 --caddr 192.168.1.1 &
    
    

    I could then access my modem by using the following:  http://192.168.3.1:8989

    (192.168.3.1 being my LAN network address)

    Now, the documentation talks about creating an Outbound NAT rule and this is where I'm stuck (or too stupid to understand!).

    From the documentation http://doc.pfsense.org/index.php/Accessing_modem_from_inside_firewall:

    On 2.0, a PPPoE WAN is actually assigned to a virtual PPPoE adapter, not the physical port. So the tricks above are not needed and the NAT portion will not work at all.

    If you already added the IP alias, remove it. If you added the IP alias via the shellcmd trick above, remove it also.

    Instead, under Interfaces > (assign), create a new OPT interface, and assign it to the physical network card that is on WAN. For example, if your WAN on the assignment page is "PPPOE0(fxp0)", choose fxp0, and Save your changes.

    So, here is a screen shot of my OPT1 interface that I assigned to the physical port:

    {Interface_Assign.jpg}

    Go to Interfaces > (your new OPT interface), and enable the interface. Give it an IP address in the same subnet as your modem, such as 192.168.1.5/24 (For example, the same IP address suggested in for the alias in the previous instructions). Do not set a gateway. If you like, you can rename the interface to something like ModemAccess.

    Here is a screen shot of the OPT1 interface enabled:

    {Interface_OPT1_Enabled.jpg}

    Add an Outbound NAT rule as described above but do NOT choose the WAN interface, choose your new OPT interface.

    You should then be able to access the modem from LAN.

    And here is the NAT Outbound:Edit:

    {Firewall_NAT_Outbound_Edit.jpg}

    So, what have I done wrong?







  • See here:  Click here


Log in to reply