Problema com Acesso remoto externo do webgui do pfsense



  • Pessoal, uma dúvida cruel, tenho um modem que não consigo fazer passar o acesso para que eu possa fazer modificações na configuração do PfSense.

    Tenho um modem Dlink DSL-2640B com Linha GVT, já tinha feito isso uma vez mas era com opticom, este aqui não vai de jeito nenhum.

    No modem estou acessando o NAT>Virtual Servers e lá configurei da seguinte forma:

    Server Name Remote Host External Port Start External Port End Protocol Internal Port Start Internal Port End Server IP Address WAN Interface Remove
    servidor 8080 8080 TCP/UDP 80 80 192.168.1.20 ppp0

    Sendo que 192.168.1.20 é o firewall

    no firewall criei uma regra na Wan, ficou desta forma:

    ID Proto Source Port Destination Port Gateway Queue Schedule Description

    TCP/UDP * * WAN net 80 (HTTP) * none

    Configurei o DynamicDNS com o No-ip e está tudo certo, mesmo assim, não está acessado, no máximo que consegui, foi abrir em uma rede externa o login e senha do modem. Alguém pode me ajudar??

    Outra informação, o pfsense está virtualizado no Vmware, sendo que a porta da internet está como NAT, pode influenciar o acesso, o ip que aparece no pfsense da wan é 192.168.60.128, já mudei a regra para este ip. mas não funciona.



  • Marcelo,

    Você esta se deparando com um conflito de portas publicadas no modem e no pfsense.

    Mude seu pfsense para conectar via https e mude a porta para por exemplo 8443.

    Desta forma seu nat vai funcionar.

    Minha sugestão é configura o pfsense com um servidor dmz do modem e passar todas as configurações para ele.

    att,

    Marcello Coutinho



  • Pessoal, consegui acessar a webgui do pfsense, mas quando coloco login e senha não entra dá uma mensagem.

    You are accessing this router by an IP address not configured locally, which may be forwarded by NAT or other means.

    If you did not setup this forwarding, you may be the target of a man-in-the-middle attack.

    o que posso fazer para corrigir o problema, já cheguei a atualizar o pfsense, mas nada…



  • Basta desabilitar a verificação de HTTP_REFERER em system -> advanced

    Disable HTTP_REFERER enforcement check 
    When this is unchecked, access to the webConfigurator is protected against HTTP_REFERER redirection attempts.
    Check this box to disable this protection if you find that it interferes with webConfigurator access in certain corner cases such as using external scripts to interact with this system.
    More information on HTTP_REFERER is available from Wikipedia.
    

Log in to reply