Rebuild 2.0.1 and restore "need multicast update callback"



  • Version: 2.0.1

    The machine is the exact same machine that was working perfect prior to rebuild. The configuration is the XML from days prior and no changes had been made in well over a month. The rebuild was due to a failing harddrive.

    Installation goes fine and the system seems to work as expected aside from being the default config and not my prior.

    I restore the configuration and the firewall reboots. At the console it gets to:

    "Configuring firewall.ral0: need multicast update callback"

    I have attempted to remove the card and this fails with:

    "Configuring firewall.: need multicast update callback"

    If I ctrl-c and specify /bin/sh I never get a shell, it simply hangs there.

    Any ideas?

    Thanks!

    <edit>BTW: The original install was 2.0 RELEASE from September.  I have not attempted to use the older version. I would think if this is a card problem it would have equal support in 2.0.1 as it did in 2.0.0.</edit>



  • 2.0 fails as well. I have removed all references to the ral0 interface from the xml file with the exact same results. Again this is the same hardware that has been running since before September and up until just weeks ago. Does restoration of the xml file work?  I find it odd Im getting this error even when no ral0 interface exists in the xml file.



  • SOLVED (kind of)…

    It would appear I still had some pfBlocker configuration settings in my backed up xml file. Those were causing the issue. I still see the multicast message so as suspected its unrelated. Manual removal of all pfBlocker references in the xml and restore seems to have worked.


Log in to reply