/etc/resolv.conf begin modified every hour or sooner



  • My /etc/resolv.conf file is auto-modified every time, it put 127.0.0.1 in there while I don't want that.

    I edited /etc/inc/system.inc, but I'm not sure if that file does that.



  • check if your dns forwarder isn't enabled

    services -> dns forwarder

    Be sure you have rules to permit traffic on dns port before disabling it.



  • You do want 127.0.0.1 there, that improves lookup performance. Why do you think you don't? You can turn that off under System>General Setup if you really want but that's not desirable in most all circumstances.



  • @cmb:

    You do want 127.0.0.1 there, that improves lookup performance. Why do you think you don't? You can turn that off under System>General Setup if you really want but that's not desirable in most all circumstances.

    My local DNS don't works (hence 127.0.0.1).  I have no 127.0.0.1 under System: General Setup too, which is weird.

    Editing the files seems to have fixed it.



  • When the DNS forwarder is enabled, it puts 127.0.0.1 in there automatically so name resolution from the firewall itself uses the performance benefits and local caching of the DNS forwarder. You can check the box under System>General Setup if you don't want it to do that, but you usually want the improved performance of the DNS forwarder (127.0.0.1).


Locked