VLANs on LAN & WAN with IPTV multicasting



  • Good day calleagues,

    I'm trying to implement mutli VLANs with IPTV support:

    Hereby I have placed a picture, where Pic. A1 is representing old system and Pic. A2 depicts new one:

    Interfaces:
    WAN (VLAN1): 88.88.88.88
    LAN (VLAN100) 192.168.1.1
    LAN OPT2 (VLAN101) 192.168.2.1

    I have configured IGMP service as follow:

    Firewall>Rules>Lan
    added rule
    Action=Pass
    Interface=Lan
    Protocol=IGMP
    Source=Lan subnet
    Destination=Network 239.2.3.0/24
    Advanced Options>checked "This allows packets with IP options to pass…"
    Rule is placed almost on top

    Firewall>Rules>Wan
    added rule
    Action=Pass
    Interface=Wan
    Protocol=UDP
    Source=any
    Destination=Network 239.2.3.0/24

    Applied all changes.

    Services>IGMP Proxy
    added upstream
    interface=Wan
    Type=Upstream Interfece
    Threshold=1
    Network(s)=88.88.88.88/24 192.168.1.1/24

    added downstream
    Interface=Lan
    Type=Downstream Interface
    Threshold=1
    Network(s)=192.168.1.0/24

    System>Advanced>Firewall/Nat
    checked Disable Firewall Scrub

    In Interfaces: WAN I have removed check mark from Block private networks в секции Private networks

    Also configured UDPXY as follow:
    At command prompt I have ran such command:
    pkg_add -r http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/udpxy.tbz

    Then renamed udpxy file (which is placed in /usr/local/etc/rc.d/) into udpxy.sh and editted it as follow:
    udpxy_enable=${udpxy_enable-"YES"}
    udpxy_flags=${udpxy_flags-" -a 192.168.1.1 -c 4 -M 60 -m 88.88.88.88"}

    Also I have added udpxy_enable="YES" into rc.conf (which is placed in /etc/defaults/)

    I have checked status of udpxy over http://192.168.1.1:4022/status

    But, no streaming over multicast with http://192.168.1.1:4022/udp/239.192.12.5:1234

    Can You help or suggest on how to fix this problem.



  • Huray, all is working.  Viva la pfsense. :D


Log in to reply