Using pap only for ppp 3g wan connection



  • My 3G provider ( Virgin in Australia ) will only connect if you use PAP. If you allow CHAP as well the connection fails. I've tried this on windoze to confirm that this is the case.
    In pfsense 2.0 both chap and pap are allowed according to the script /var/etc/mpd_xxx.conf.
    I can manually edit the line in the script from
    set link accept chap pap eap
    to
    set link accept pap

    and save it. every time I save the config for that interface is gets overwritten.
    So, I could find the script that creates this one and edit it the same but my adsl pppoe wan interface uses chap so it needs the original script format that tried both.

    Q1.Is there any gui option to select the auth type?
    Q2. An I unique or does anyone else require this?



  • @greybeard:

    Q1.Is there any gui option to select the auth type?
    Q2. An I unique or does anyone else require this?

    1. No
    2. I don't want it at present BUT it would be useful if I ever want to use Virgin mobile broadband as a backup to ADSL. Ubuntu since at least 10.04 has allowed selection of PPP authentication options


Log in to reply