Can't get an internet connection!?



  • Hi guys, sorry if this is the wrong place to put this - I got the impression that the routing subforum was just for multi-wan setups.

    Basically, I have set up PFSense and it has two NICs, one for WAN, one for LAN.

    It works as expected and the LAN can ping WAN addresses and the other way round, so, I am confident that I have set it up correctly.

    However, I have assigned a gateway to the WAN interface (which the machine can ping, and this is the same IP that other machines use for the gateway), but, nothing appears to happen.

    I just tried basically pinging Google @ 8.8.8.8 and I get no response, along with other local IPs.

    I have set up a few PFSense installations in the past without a problem and I have read some guides but this has just thrown me completely. It isn't a complex setup or anything advanced - I just can't seem to work this out.

    Again, the gateway has been set on the WAN and I can ping it, but, PFSense doesn't seem to be routing through it.

    PFSense is running on a VM and just to make sure I wasn't being crazy, I stopped the VM and used a standard Linux install, then I configured it for the same IP/Gateway and everything worked fine - so… I just can't understand what is wrong here.

    Can anyone help?



  • Machines can Ping this gateway through pfsense or this gateway is on lan network?



  • Sorry if I was confusing.

    I have WAN with public ip addresses, all on a /28 subnet.

    I have Lan with NAT'ed addresses.

    Every machine on the LAN interface (and PFSense locally from console) can ping machines on the WAN's subnet, but not machines outside the subnet (e.g. Google's 8.8.8.8).

    Machines on the WAN can ping PFSense's IP.

    It just seems there is a problem with forwarding to the gateway, but, I can't see anything wrong here. I thought I only need to set the gateway on the WAN, should I have also set it on the Lan?



  • Did you defined any gateway as default on system -> routing?

    Enabling this, you can see that no interfaces requires a gateway(of course you can set if you want).


Log in to reply