Add static route for half bridge wan



  • I have a thomson 787v modem and I need to connect to my isp over pppoa so I cant fully bridge it.
    I need to put it in half bridge or dhcp spoofing.
    What it means is my pfsense router wil get the wan ip adres.
    Getting the modem in half bridge mode is not te problem it works fine and I can connect an windows machine to it which gets the wan ip adres and have internet acces
    But when I connect the pfsense machine to it it doest gets a correct ipadres and the same gateway as the windows machine but no internet.

    my wan ip adres is 188.x.x.x
    and the gateway is 62.x.x.x

    After some googling I found what I think is the solution :
    http://wlug.org.nz/Half%20bridge%20with%20PPPoA

    LINUX STATIC ROUTE FIX

    Windows doesn't seem to mind the gateway being in a different subnet, but Linux does.

    "… the reason is that the router issues a DHCP lease with a default route outside of the IP/Netmask of the interface. Eg: DHCP issues IP=202.36.240.10/255.255.255.0 and a Gateway address of 202.36.1.1 Windows happily handles this (as you've noted). Linux's routing tables don't off the cuff. The solution is to create a static host route to the gateway, then set it as the default route. eg:

    route add -host 202.36.1.1 dev eth0

    route add default gw 202.36.1.1 dev eth0

    So I need to add a static route  but I dont know how or which one.
    Could sombody exlplain to me how I could add the suggested fix?

    Thanx in advance Wybren



  • In the hope that the gateway will be within the network scope the Speedtouch converts the /32 network into a ridiculous big network (a 255.0.0.0). This isn't always enough for some ISP's.

    The workaround is to add the gateway as a host and as gateway.
    In your case that's the 62.x.x.x address.

    It would be nice if pfsense lets you enter a static address with a 255.255.255.255 subnet and a gateway which is, of course, outside that scope. Have you tried that?

    If not, you could ask the devs to make this enhancement…
    They did this for DD-WRT



  • What I've tried is adding the gateway manually but it didn't make any difference.
    And I,v,e tried to add a static route in system->routing->routes
    But it didn't make any difference. I'm not sure if iv's did it the right way.
    this were the settings
    Destination network : my wan ipadress 188.x.x.x
    gateway : the 62.x.x.x

    The workaround is to add the gateway as a host and as gateway.
    In your case that's the 62.x.x.x address.

    How do I add the gateway as host?

    It would be nice if pfsense lets you enter a static address with a 255.255.255.255 subnet and a gateway which is, of course, outside that scope. Have you tried that?

    Do you mean enter the wan ipadres as a static adres?

    Thanx again Wybren


Log in to reply