Post 2.0.1 Upgrade - Cannot modify Dashboard after LB is activated



  • Hello Everyone,

    I have been trying upgrade my 2.0 install to 2.0.1 and have been having some issues. After a clean installation, I re-applied the old configuration and this caused the Dashboard to revert to what is shown in screenshot 3. In that state if any changes made to the Dashboard, including re-ordering widgets, removing them or adding new ones this is not saved.

    During the troubleshooting I found that this issue only appears if there are any Load Balancer Virtual Servers active. I removed all the Virtual Servers and the Dashboard immediately goes back as seen in screenshot 1.

    I took a look at the configuration files (before and after, which are both attached) and don't see anything too different with this.

    Does anyone else know what is going on? I tried to do this from scratch. Did this troubleshooting with my config and with a clean install. I start with a dashboard with the configuration shown in screenshot 1, add a load balancer pool and virtual server and the dashboard then gets all screwed up. Does anyone have any ideas?

    Thank you,

    Robbert

    Screenshots:
    http://rrijkse.com/pfsense/1.png
    http://rrijkse.com/pfsense/2.png
    http://rrijkse.com/pfsense/3.png

    Config:
    http://rrijkse.com/pfsense/config-gw2-after.xml
    http://rrijkse.com/pfsense/config-gw2-before.xml


  • Rebel Alliance Developer Netgate

    Have you tried this without your custom user, just as admin, on a clean setup?

    Or perhaps giving that user a different name? pfsync may be a reserved word somewhere, probably not a good idea to use that as a group name. If that is to blame we may need to block it out in the GUI.

    It may be that with the LB bits active it's trying to reach a page that user doesn't have permission to, and getting an error. The syslog log would be helpful to see.



  • Thanks for the reply Jimp,

    Those screenshots were all taken when I was logged in with the admin user. I was using the pfsync user to synchronize the configurations between the two nodes in the cluster, but that was giving me issues so I reverted to using admin for that as well. I just haven't cleaned up the user yet.

    @rrijkse:

    I tried to do this from scratch. Did this troubleshooting with my config and with a clean install.

    Now that I read the above line again it should have read something along these lines:
    I tried to do this procedure with my configuration and with a clean configuration, both on top of a clean installation and saw the same results.

    I don't have the log files anymore, but will reproduce the issue with a clean install/config tonight and post them. From the notes I took when I did another install last night, I can reproduce the error every time if I follow this procedure, whether on a clean config or my old:

    1. Login as the admin user.
    2. Re-arrange/add the widgets on the dashboard page to look like screenshot 1.
    3. Goto Services -> Load Balancer.
    4. Add a new Load Balancer Pool and Virtual Server, like screenshot 2.
    5. Back to the dashboard and everything looks like screenshot 3.

    Let me know if you need any further information.

    Thank you,

    Robbert


  • Rebel Alliance Developer Netgate

    OK, so there is no widget below the Services Status widget in screenshot 1?

    The real way to tell would be to just use the <widgets>section of your config at that point in time - does that correspond to either of your posted configs?</widgets>



  • I have reproduced it with just the widgets visible in screenshot 1, but also a mix of other widgets. The widget sections of the configuration config-gw2-after.xml is what is shown in the screenshots, but I had the same issue with the other configuration posted.

    Both of those configurations work properly when using a 2.0 installation. When I reproduce and post the logs I will post a new configuration as well.

    Robbert


  • Rebel Alliance Developer Netgate

    ok, I will attempt to reproduce it tomorrow.



  • I have attached the SystemLog, and a before/after configuration. I only had the "Services" and the "Load Balancer" widgets active in this try and after I setup a virtual server the dashboard was re-arranged again.

    It "lost" the "Load balancer" widget and gained the "Captive Portal Status", "Interfaces" and "Traffic Graphs" widgets.

    Robbert

    SystemLog.txt
    config-pfSense-beforeLBconfig.txt
    config-pfSense-afterLBconfig.txt



  • I just tried just one widget, first tried it with the "Load Balancer" widget and after I setup a Virtual server the dashboard still worked fine. However I modified the dashboard to only have the "Services" widget and immediately it reverted back to the following configuration and was unable to update the dashboard configuration after that.

    Column 1:
    Service Status
    Captive Portal Status
    Interfaces

    Column 2:
    Traffic Graphs

    Hope this helps,

    Robbert


  • Rebel Alliance Developer Netgate

    Yeah I already found and figured the problem out:

    https://github.com/bsdperimeter/pfsense/commit/eb7454c4491c38c183f4c37df0a0987fe9114e24

    It was the code bit in the services status widget that was to blame there.



  • Thank you, I have confirmed this patch fixes the issues.

    Robbert


Log in to reply