HAPROXY 1.4.18 pkg v 1.2 PHP Error on PFSense 2.0.1-RELEASE AMD64



  • On a upgraded installs of pfsense (where the previous version was upgraded from 2.0RC3 -> 2.0 -> 2.0.1) where the HAPROXY package is installed after the fact (and reinstalled to test to see if the error goes away) I get this error on HAPROXY under the server pools tab:

    Fatal error: Cannot use string offset as an array in /usr/local/www/haproxy_pools.php on line 127

    This makes the package unconfigurable.

    It does not seem to matter if HAPROXY has configuration or not the error message is constant.



  • After doing a fresh install of PFsense 2.0.1 and installing the package the issue went away so I can only conclude there is a package management problem that occurs if you upgrade your firmware in the same manner that I did. See below.



  • I've just pushed a fix for that array check error.  :)



  • @marcelloc:

    I've just pushed a fix for that array check error.  :)

    Yay I like fixes. Thank you. Does that mean my earlier fresh install test may have picked up your fix?



  • Not sure,

    But if you reinstall in few minutes I'll be 100% sure you got the fix.

    I did not changed package version, just fixed the array check.

    att,
    Marcello Coutinho


Log in to reply