Usb 3g device not detect



  • hi all
    I need somebody guide me to resolve my problem. I have HUAWEI E173 and I already read on http://doc.pfsense.org/index.php/Known_Working_3G-4G_Modems, so I not sure about my E173 is really support with PF-Sens 2.01. and how I do next.

    dmesg | grep usbus1

    usbus1: EHCI version 1.0
    usbus1: <amd cs5536="" (geode)="" usb="" 2.0="" controller="">on ehci0
    usbus1: 480Mbps High Speed USB v2.0
    ugen1.1: <amd>at usbus1
    uhub1: <amd 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usbus1
    Root mount waiting for: usbus1 usbus0
    Root mount waiting for: usbus1
    ugen1.2: <huawei>at usbus1
    umass0: <huawei 0="" 2="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 1.02,="" addr="">on usbus1
    umass1: <huawei 0="" 2="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 1.02,="" addr="">on usbus1

    usbconfig -d ugen1.2 dump_device_desc

    ugen1.2: <huawei mobile="" huawei="">at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON

    bLength = 0x0012
      bDescriptorType = 0x0001
      bcdUSB = 0x0200
      bDeviceClass = 0x0000
      bDeviceSubClass = 0x0000
      bDeviceProtocol = 0x0000
      bMaxPacketSize0 = 0x0040
      idVendor = 0x12d1
      idProduct = 0x1c0b
      bcdDevice = 0x0102
      iManufacturer = 0x0002  <huawei>iProduct = 0x0001  <huawei mobile="">iSerialNumber = 0x0000  <no string="">bNumConfigurations = 0x0001

    Thank you</no></huawei></huawei></huawei></huawei></huawei></huawei></amd></amd></amd>



  • after play a moment with my 3G usb I got a real information about it, my usb 3g is E173s so it did not support current by PF-Sense.

    and I got something from http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=552

    # Huawei E173s
    
    DefaultVendor=  0x12d1
    DefaultProduct= 0x1c0b
    
    TargetVendor=  0x12d1
    TargetProduct= 0x1c05
    
    CheckSuccess=20
    
    MessageEndpoint= 0x0f
    MessageContent= "55534243000000000000000000000011060000000100000000000000000000" 
    

    any body have idea? ??? ???


Log in to reply