TrendNet tew 645ub device ??



  • Hello,

    First, i'm french so sorry for my accent.

    I will install pfsense with my USB Wireless TrendNet tew 645ub , but pfsense not recognize this device.

    When i plug, i have just " ugen4.2 <ralink>at usbus4</ralink>" and i cannot use.

    Thank you.
    Best regards,


  • Netgate Administrator

    If you're lucky this may be supported by the run(4) driver.
    However I don't see it in the source.

    If it is you will need to load the firmware. Add these lines to /boot/loader.conf.local (create the file if it doesn't exist):

    
    if_run_load="YES"
    runfw_load="YES"
    
    

    Steve



  • Hi and thank you for your answer. :)

    i have create the file loader.conf.local and i have add the 2 lines. ( loader.conf exist ? it's not a problem ?)
    How i load the firmware ?


  • Netgate Administrator

    loader.conf has the standard boot time options and loader.conf.local has any custom options you need. loader.conf.local is copied across if you do a firmware update where as loader.conf is overwritten.

    Reboot the box and the firmware should be loaded.
    This will only do anything if the run driver recognises your usb adapter.

    Steve



  • Ok thank you..

    I have reboot my PC and it's not recognize :(

    I have 2 devices ;

    TrendNet tew 645ub
    and
    DW-131 Dlink.

    and the same error.

    ugen4.2 : <ralink>at usbus4
    and
    urgen 4.3 : <vendor 0x07d1="">I'm not lucky :(

    I search the best wifi card for my access point with large distance  , you know what is the best ?

    Thank you for all.</vendor></ralink>


  • Netgate Administrator

    If you want to use the wifi adapter as an access point it must support hostap mode.
    Before giving up on the two you have try plugging them both in and running at the console:

    usbconfig dump_device_desc
    

    This will give you enough information to determine if they are supported at all.

    The best source of information on wifi adapters is JimP's spread sheet:

    https://docs.google.com/spreadsheet/ccc?key=0AojFUXcbH0ROdHgwYkFHbkRUdV9hVWljVWl5SXkxbFE&hl=en#gid=0

    Steve



  • @larsN:

    I have reboot my PC and it's not recognize :(

    When you have the TEW-645UB plugged in does the startup say something like:

    ugen0.5: <ralink>at usbus0
    run0: <1.0> on usbus0
    run0: MAC/BBP RT3070 (rev 0x0201), RF RT2020 (MIMO 1T1R), address d8:5d:4c:98:3b:7f
    run0: firmware RT2870 loaded</ralink>

    If so the OS has recognised the device and you then have to (in the pfSense GUI) add it to the pool of devices pfSense uses.

    So when you say not recognised what are you looking for that hasn't happened?



  • When you have the TEW-645UB plugged in does the startup say something like:
    Quote
    ugen0.5: <ralink>at usbus0
    run0: <1.0> on usbus0
    run0: MAC/BBP RT3070 (rev 0x0201), RF RT2020 (MIMO 1T1R), address d8:5d:4c:98:3b:7f
    run0: firmware RT2870 loaded

    If so the OS has recognised the device and you then have to (in the pfSense GUI) add it to the pool of devices pfSense uses.

    So when you say not recognised what are you looking for that hasn't happened?</ralink>

    Hi, when i plug my device, i have just ugen0.5: <ralink>at usbus0</ralink> and i can't choice my device in the pfsense GUI.

    The best source of information on wifi adapters is JimP's spread sheet:

    https://docs.google.com/spreadsheet/ccc?key=0AojFUXcbH0ROdHgwYkFHbkRUdV9hVWljVWl5SXkxbFE&hl=en#gid=0

    Steve

    Thank you.



  • I have this when i writing usbconfig dump_device_desct for my TrendNet tew 645ub

    Blengh : 0x0012
    DdescriptorType : 0x0001
    BcdUSB : 0x0200
    BdeviceClass : 0x0000
    BDevice SubClass : 0x0000
    BdeviceProtocol : 0x0000
    BMaxPacketSize0 : 0x0040
    Ivendor : 0x157e
    IdProduct : 0x3013
    BcdDevice : 0x0101
    Imanufactur : 0x0001 <ralink>Iproduct : 0x0062 <802.11N WLAN>
    IserialNumber : 0x0003 <1.0>
    Bnumconfigurations : 0x0001

    But i don't know what is it?

    If i buy a wireless card, what do you think about this : http://www.ldlc.com/fiche/PB00066238.html (atheros card, the best from JimP's spread sheet ).. but it's not at http://www.freebsd.org/releases/8.1R/hardware.html

    Can you confirm ?

    I search a wifi card N compatible Pfsense 2.0.1 with an separate antenna , but i don't find.</ralink>



  • @larsN:

    I have this when i writing usbconfig dump_device_desct for my TrendNet tew 645ub

    Apparently this device s supported by the same Linux driver that supports a device supported by the FreeBSD run driver. But the config output shows a TrendNet Vendor code (0x157e) and it appears that this vendor code is not in the list of supported devices in the FreeBSD run driver. Maybe adding this device's code will be sufficient to get it to work with the run driver, maybe that won't be enough.

    @larsN:

    If i buy a wireless card, what do you think about this : http://www.ldlc.com/fiche/PB00066238.html (atheros card, the best from JimP's spread sheet ).. but it's not at http://www.freebsd.org/releases/8.1R/hardware.html

    Can you confirm ?

    That card is a D-Link DWA556 PCI-Express card. If I recall correctly there has been at least one reference to that card in the pfSense forums. A search might turn up a report from an actual user.

    @larsN:

    I search a wifi card N compatible Pfsense 2.0.1 with an separate antenna , but i don't find.

    Are you looking for a WiFi card with a detachable antenna and supported in pfSense? The Alfa AWUS036NH appears to have the same chipset as a device I have that works with the run driver on pfSense 2.0.1. I have seen references to this device in the pfSense forums.


Log in to reply