Smb_auth erro squid



  • Estou tentando fazer o squid autenticar via samba aqui porem ele da um erro!
    Eu coloco o comando no shell:```
    /usr/local/libexec/squid/smb_auth -d -W OMEUDOMINIO -U 192.168.200.3

    E quando eu digito meu usuario espaco senha aparece:
    

    domain name: OMEUDOMINIO
    pass-through authenticaton: no
    query address option: -U 192.168.200.3 -R
    /usr/local/libexec/squid/smb_auth.sh: /usr/local/bin/nmblookup: not found
    Domain controler IP address:
    ERR

    
    Procurei esse nmblookup no pfsense porem ele nao existe! Alguma ideia?
    
    Grato!


  • você instalou o samba neste pfsense?



  • nao, o samba esta instalado so no meu servidor de arquivos (192.168.200.3).

    e mesmo assim nao tem muita logica, porque no centos aqui tb nao tem o samba e com o mesmo comando eu consigo autenticar!



  • @diegogyn:

    nao, o samba esta instalado so no meu servidor de arquivos (192.168.200.3).

    e mesmo assim nao tem muita logica, porque no centos aqui tb nao tem o samba e com o mesmo comando eu consigo autenticar!

    Infelizmente diego, tem logica sim.

    http://linux.die.net/man/1/nmblookup
    Name

    nmblookup - NetBIOS over TCP/IP client used to lookup NetBIOS names

    Synopsis

    nmblookup [-M] [-R] [-S] [-r] [-A] [-h] [-B <broadcast address="">] [-U <unicast address="">] [-d <debug level="">] [-s <smb config="" file="">] [-i <netbios scope="">] [-T] [-f] {name}

    Description

    This tool is part of the samba(7) suite.

    Digita um rpm -qa no seu centos para ver os pacotes instalados, o samba/winbind devem estar lá.</netbios></smb></debug></unicast></broadcast>



  • Assim nao faz logica pq o squid nao e dependente do samba, mas no caso parece que ele precisa de alguma bibliotecas do samba!
    Instalei aqui os pacotes do smbclient e o nmplookup!

    Agora ele fala que ta faltando 3 lib: ld-elf.so.1 libcrypt.so.4 e libtalloc.so.2

    Achei que era do openssl porem instalei ele e continua dando a mensagem, algum ideia de qual pacote possa ser??

    []'s



  • @diegogyn:

    Assim nao faz logica pq o squid nao e dependente do samba, mas no caso parece que ele precisa de alguma bibliotecas do samba!

    Então ele depende do samba  ;)

    @diegogyn:

    Instalei aqui os pacotes do smbclient e o nmplookup!

    Agora ele fala que ta faltando 3 lib: ld-elf.so.1 libcrypt.so.4 e libtalloc.so.2

    Achei que era do openssl porem instalei ele e continua dando a mensagem, algum ideia de qual pacote possa ser??

    []'s

    De qual repositório você esta baixando os pacotes?

    ftp-archive da 8.1?





  • você esta usando a versão 1.2.3?



  • 2.0.1



  • @diegogyn:

    2.0.1

    você instalou pacote da versão 7 do freebsd na 8,1

    remova todos os pacotes que o samba instalou e faça a instalação a partir deste repositorio

    i386
    http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/

    post relacionado ao samba no pfsense.
    http://forum.pfsense.org/index.php/topic,44662.0.html



  • mesmo erro quando eu digito usuario e senha aparece:

    
    /libexec/ld-elf.so.1: Shared object "libcrypt.so.4" not found,required by "libtalloc.so.2"
    

    antes apareceu uma biblioteca diferente dai eu instalei o openldap-client e ele voltou a dar o erro!

    ====

    RESOLVIDO! (E FODA MSM)

    Hehehehehe! Pra funcionar voce tem que instalar 5 pacotes:
    samba34-libsmbclient.tbz
    samba34-nmblookup.tbz
    samba34-smbclient.tbz
    libmycryp.tbz
    talloc.tbz

    E depois que voce fizer isso ainda nao vai funcionar! ;)

    Ai vc tem que ir dentro do arquivo smb_auth.sh e adicionar o -U $USER na linha abaixo:

    
    authinfo=`$SAMBAPREFIX/bin/smbclient "//$dcname/$AUTHSHARE" -U $USER -I $dcip -d 0 -E -W "$DOMAINNAME" -c
       "get $authfilebs -" 2>/dev/null` 
    

    Funcionou fazendo o comando, agora eu tenho que testar com o squid rodando pra ver se funciona tambem!

    Tem como pedir para a equipe de desenvolvimento fazer essa alteracao no arquivo e ja colocar esses pacotes como padrao no pfsense!?

    Valew pela ajuda!



  • Valeu pelo retorno.

    Vou colocar estr post na lista de howto do squid com samba.

    Esta autnticação funciona transparente igual a ntlm?



  • Essa e so para squid autenticado, nunca usei o ntlm,
    acho que no plugin do squid devia ter mais opcoes de autenticao pois, ai eu tenho que ficar adaptando o arquivo squid.conf, sem falar que quando eu fizer alguma alteracao via paniel perde tudo que eu fiz!

    Ainda bem que no caso do smb_conf e so colocar o modo de autenticacao como none, jogar as linhas abaixo nas custom option:

    
    auth_param basic program /usr/local/libexec/squid/smb_auth -W MEUDOMINIO -U 192.168.200.3
    auth_param basic children 5
    auth_param basic realm Digite sua senha da rede
    auth_param basic credentialsttl 60 minutes
    acl password proxy_auth REQUIRED
    http_access allow password localnet
    

    AI caso eu tenha que fazer alguma configuracao via webadmin ou voltar um backup e so comentar a ultima linha que o sistema gera:
    #http_access allow localnet

    Eu vou fazer um tutorial mais organizado e depois jogo aqui no forum! ;)



  • @diegogyn:

    Essa e so para squid autenticado, nunca usei o ntlm,

    O ntlm usa as credenciais do windows para autenticar sem aparecer tela de usuário e senha.



  • Ha tipo se o cara logou no windows, ele já navega automático?
    Interessante, porem pelo que eu li tem que ter o AD, nunca mexi! hauhauha!

    Mas pelo que eu vi e o mesmo principio, do smb_auth, só que no caso e menos seguro, se o cara sair do pc alguém pode ir la e navegar!
    Como o pessoal aqui tem o costume de bloquear o pc só no almoço e não quando vao ao banheiro (Apesar que e so apertar Win+D) acho melhor pedir senha toda vez que acessar a internet. (Se bem que tem uns que gravam a senha no browser tb kkkkkkkkkk)


Log in to reply