HP DL145 (G3?) will not boot off USB cdrom



  • Just a warning to all that might try out pfSense on HP's DL145 boxes.  There's a FreeBSD bug that's preventing this hardware from booting via USB CD-ROM.  The internal CD-ROM (if you bought it!) should work - it'll be a couple days before I can test this as we're having to order one at work currently.

    –Bill



  • NO hardware will boot off USB CD-ROM AFAIK. Not pfsense nor a stock FreeBSD 6.1 or 6.2 CD. There's another thread on here somewhere about it.



  • Fair enough, never had to try booting FreeBSD from usb cd-rom, just assumed that it worked since OpenBSD and linux worked fine.  Either way, this is a warning to others - it's a somewhat longstanding FreeBSD bug, not a pfSense bug.

    –Bill



  • I recall somebody posting a fixed btx loader or something to freebsd-stable maybe a couple weeks ago, but with the caveat that it wasn't "well tested" and it didn't sound like it would be committed. It was for 6.1 IIRC. The person who tried it reported that it fixed USB CD-ROM's.

    People know the issue exists, it just doesn't seem like anybody cares enough to get a fix committed.  :/



  • You must be talking about this patch: http://people.freebsd.org/~kib/realbtx/



  • I confirm that there is no problem with internal CD-ROM.



  • Yeah, what Scott linked is what I was referring to.


Log in to reply