FAILOVER RESUME PROBLEM



  • Goodmorning,

    I have a problem with failover configuration.

    My pfsense have two gateway in two different ethernet

    Pfsense version is 2.0.1

    GW1 default
    GW2 only for failover

    In routing group they are:

    GRPFAILOVER
    GW1 TIER1  MONITOR IP 1
    GW2 TIER2  MONITOR IP 2

    In my nat configuration routing is associated to GRPFAILOVER

    Whent GW1 go to down (disconnect ethernet) GW2 became active and my lag go with this

    But when I re-connect GW1, pfsense don't return to GW1 default gw…

    Where I wrong?

    Thanks



  • The default gateway switching is off by default because it has issues in some circumstances, sounds like yours is among those. It was removed entirely, but some people complained that it worked for what they were doing, so it was brought back as a non-default option that has known problems. You'll have to dig into the code, or just manually change the default gateway back. In most circumstances you should be using only gateway groups and don't need the default gateway to move.



  • Ok.

    So I can't return to tier1 gateway? Return to the standard gateway is an important feature.

    I have a single gateway group but I can't return to the most important gw in manual mode.

    Where is the code to edit for test this features?

    Thanks.

    @cmb:

    The default gateway switching is off by default because it has issues in some circumstances, sounds like yours is among those. It was removed entirely, but some people complained that it worked for what they were doing, so it was brought back as a non-default option that has known problems. You'll have to dig into the code, or just manually change the default gateway back. In most circumstances you should be using only gateway groups and don't need the default gateway to move.



  • Things that go to a gateway group switch back when the other WAN comes back online, that's not what I was referring to. The default gateway switching functionality is separate from that.


Log in to reply