Acess ap problem



  • Hi,

    I just atached to my pfsense machine one ap from linksys WRT54GL , router ip :192.168.2.1 pfsense 192.168.1.1 from 192.168.2.1-as ap client i can acess 192.168.1.1 but in revers is not working ? i'm missing something ?

    Thanks !



  • Sounds like you're using NAT on the Linksys, which you don't want. See http://doc.pfsense.org/index.php/Use_an_existing_wireless_router_with_pfSense



  • See atached photo , router is not sharing internet with ip like this 192.168.1.5 or others changing 5 it's sharing internet only if i change ip class like this 192.168.2.1 as seen in photo, also i can't acess router local ip 192.168.2.1 as direct client of server from switch(my pc) only revers.

    Nat is not setted.

    Thanks!




  • Considering the grammar is horrendous, here's what I gather:

    You have your WRT54GL connected to your switch via the WAN port configured as a gateway to serve WIFI, you set your local ip to 192.168.2.1 which serves your WIFI clients on the 192.168.2.0/24 network (I'm presuming the IP from that wifi client is a typo and should be 192.168.2.20).

    Your wifi clients can ping the 192.168.1.0/24 network because WRT54GL has a default route back to PFsense which knows how to get to the 192.168.1.0/24 network.  Your LAN clients on 192.168.1.0/24 can NOT ping (or access) the 192.168.2.0/24 network because it's a LAN address on the other end of an internet gateway.

    Reserved addresses are not routable over the internet.  Imagine if you bypassed PFsense and connected a cable modem directly to the WAN port of your WRT54GL.  What you're trying to do is the equivalent of people on the internet being able to access your local WIFI clients directly via the 192.168.2.20 address, which can't be done.

    Unless there's a router between the networks, you have to be on the same LAN segment in order to communicate… i.e. you will only be able to access 192.168.2.1/24 from the 192.168.2.0/24 network.  If you want to connect to your WRT54GL from the 192.168.1.0/24 network, find out what IP WRT54GL is getting from PFsense (status -> dhcp leases) and connect to that IP. Also, remember if you want to connect to your WRT54GL thru the WAN interface, you have to enable remote management or it will not connect.

    Unless you have a need to segment your wireless traffic, take cmb's advice and simplify your setup, so you're not double NATing... i.e. on WRT54GL, disable DHCP and DNS relay (if its there), remove the cable from the WAN port and plug it into a LAN port, finally set a local ip on the 192.168.1.0/24 network (outside of the dhcp range on PFsense) for admin access.



  • Hi,

    Sorry for my poor english !
    Thanks ! it's working now, i manage to set linksys router like my pfsense (to enter from outside, i mean exterior ip), now i can enter in router settings as  client of my pfsense machine/server (wan ip assigned by pfsense dhcp server to router).

    Regards.


Log in to reply