HAVP [0.91_1 ] pfSense [2.0.1 i386]



  • Do I simply have something configured incorrectly? If the package has issues Id be curious to hear what level of funding would be asked to get it working correctly and if anyone considers it important enough to have operational.  Thanks!

    Expectations:
    -Firewall rule additions. Unsure how it works on the backend in this mode so maybe not…
    -Hit the EICAR test site (tried several as well as a local download) and get a denial page or at least a hit in the log or gui.

    Results:
    None of the above. It seems to simply not do anything and Im guessing its a firewall rule routing issue.

    I just installed HAVP a short time ago, updated all of the CVDs and set it to:
    Proxy mode: Transparent
    Proxy Interface(s): LAN
    Language: English
    Block file if error scanning: ON
    Scan Images: ON
    Log: ON
    Syslog: ON
    ***The rest are defaults.

    clamd is up and running no problem.
    havp is up and running no problem.

    Logs seem to indicate a firewall update and a signature test pass:
    Feb 11 07:10:56 ares php: /pkg_edit.php: Starting HAVP
    Feb 11 07:10:58 ares check_reload_status: Syncing firewall
    Feb 11 07:11:02 ares havp[15323]: === Starting HAVP Version: 0.91
    Feb 11 07:11:02 ares havp[15323]: === Mandatory locking disabled! KEEPBACK settings not used!
    Feb 11 07:11:02 ares havp[15323]: Running as user: havp, group: havp
    Feb 11 07:11:02 ares havp[15323]: Use transparent proxy mode
    Feb 11 07:11:02 ares havp[15323]: –- Initializing Clamd Socket Scanner
    Feb 11 07:11:02 ares havp[15323]: Clamd Socket Scanner passed EICAR virus test (Eicar-Test-Signature)
    Feb 11 07:11:02 ares havp[15323]: –- All scanners initialized
    Feb 11 07:11:02 ares havp[15545]: Process ID: 15545



  • PEBCAK.  :-[  Reviewed my old configs and apparently "internal" was used with custom routing rules. I simply did not have squid installed for this new configuration.



  • Hy,

    Can you help me? I have the same troublem, but I want to use transparent option. That you can confirm that transparent mode have trouble?


Log in to reply