SquidGuard + IE9



  • I have a strange problem that only appears to affect IE9 and Firefox 10.

    I have Squid + SquidGuard installed on my pfSense 2.0.1 system.  This all works perfectly well on my windows XP and Server 2003 systems (with IE8)

    If I configure my browser to use the proxy and access a site that has been blacklisted, I receive my proxy denied error.  However, if I remove the proxy from my browser I continue to receive the denied error - I shouldn’t.

    I can disable SquidGuard or whitelist the site to no avail.  If I turn off the pfSense system, I still cannot access the site but it doesn’t display proxy denied error.

    To regain access to the site I have to reset my browser back to defaults, simply clearing browser history does not help.

    Does anyone have any ideas?
    Thank you.



  • You have to change squidguard answer form 301(permanent) to 302(temporary).



  • @marcelloc:

    from 302(permanent) to 301(temporary).

    Probably vice versa.

    Indeed many browsers cache 301 redirect.



  • @dhatz:

    Probably vice versa.

    Thanks dhatz. One more typo fro my collection  :)



  • Thank you for the interesting response.

    As far as i am aware, squidGuard error page is using a 302 redirect.  Even if i configure the denied error message to be a blank page i have the problem.


Log in to reply