ZTE 3g/hspda modem working on pfsense 2.0.1(pc platfrom) ?



  • Hi,

    I want to use one modem zte HSUPA USB STICK MODEL: MF 190 with pfsense 2.0.1, in usb config is recognized :

    ''ugen3.2: <zte wcdma="" technologies="" msm="" zte,incorporated="">at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON''  (usbconfig),

    ugen3.2: <zte wcdma="" technologies="" msm="" zte,incorporated="">at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (usbconfig dump_device_desc)

    bLength = 0x0012
      bDescriptorType = 0x0001
      bcdUSB = 0x0200
      bDeviceClass = 0x0000
      bDeviceSubClass = 0x0000
      bDeviceProtocol = 0x0000
      bMaxPacketSize0 = 0x0040
      idVendor = 0x19d2
      idProduct = 0x0117
      bcdDevice = 0x0000
      iManufacturer = 0x0003  <zte,incorporated>iProduct = 0x0002  <zte wcdma="" technologies="" msm="">iSerialNumber = 0x0004  <mf1900rdsd010000>bNumConfigurations = 0x0001

    In assigned interfaces is not showned ? i'm missing something or modem is not recognized like it should be ?
    I want to use this connection as a secondary connection to internet.

    Please help !</mf1900rdsd010000></zte></zte,incorporated></zte></zte>



  • nobody can tell me if is some way for this modem to work with pfsense ?


  • Netgate Administrator

    Most ZTE modems can be locked in modem mode using a few AT commands. E.g.
    http://3g-modem.wetpaint.com/page/ZTE+AT-commands

    I take it that your modem is not supported by u3g?

    You could try the recent port of usb_modeswitch. See this thread.

    Steve


Log in to reply