ISO Building Error On FreeBSD 8.1 (cdrtools)



  • How can i fix this error on FreeBSD 8.1;

    
    pfSense# ./build_iso.sh
    
    >>> Using /usr/home/pfsense/tools/builder_scripts/remove.list.iso.8 ...
    >>> Updating system clock...
    18 Feb 10:08:17 ntpdate[2632]: step time server 188.124.15.163 offset -3.867920 sec
    >>> Operation ./build_iso.sh has started at Sat Feb 18 10:08:17 EET 2012
    >>> Building /usr/ports/sysutils/cdrtools ...gmake[2]: Entering directory `/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/inc'
    cc -O2 -pipe -fno-strict-aliasing -DSCHILY_BUILD -IOBJ/i386-freebsd-cc -I../incs/i386-freebsd-cc -I../include -I/usr/local/include -I/usr/local/include -D__OPRINTF__ i386 -c -o OBJ/i386-freebsd-cc/align_test.o align_test.c  
    cc: i386: No such file or directory
    gmake[2]: *** [OBJ/i386-freebsd-cc/align_test.o] Error 1
    gmake[2]: Leaving directory `/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/inc'
    ==> MAKING "all" ON SUBCOMPONENT "SRCROOT/inc/avoffset.mk"
    gmake[2]: Entering directory `/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/inc'
    --
    gmake[2]: Entering directory `/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/inc'
    cc -O2 -pipe -fno-strict-aliasing -DSCHILY_BUILD -IOBJ/i386-freebsd-cc -I../incs/i386-freebsd-cc -I../include -I/usr/local/include -I/usr/local/include -DUSE_SCANSTACK -D__OPRINTF__ i386 -c -o OBJ/i386-freebsd-cc/avoffset.o avoffset.c  
    cc: i386: No such file or directory
    gmake[2]: *** [OBJ/i386-freebsd-cc/avoffset.o] Error 1
    gmake[2]: Leaving directory `/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/inc'
    gmake[1]: *** [all] Error 2
    gmake[1]: Leaving directory `/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/inc'
    ==> MAKING "all" ON SUBDIRECTORY "SRCROOT/include"
    gmake[1]: Entering directory `/usr/ports/sysutils/cdrtools/work/cdrtools-3.00/include'
    --
    cc -M -DSCHILY_BUILD -IOBJ/i386-freebsd-cc -I../incs/i386-freebsd-cc -I../include -I/usr/local/include  -I/usr/local/include    -Istdio -DUSE_SCANSTACK -DPORT_ONLY   setfp.c \
    | sed -e 's;^\(.*\)\.o[ ]*:;OBJ/i386-freebsd-cc/\1.o \1.d:;' > OBJ/i386-freebsd-cc/setfp.d
    In file included from setfp.c:21:
    ../include/schily/avoffset.h:52:23: error: avoffset.h: No such file or directory
    cc -M -DSCHILY_BUILD -IOBJ/i386-freebsd-cc -I../incs/i386-freebsd-cc -I../include -I/usr/local/include  -I/usr/local/include    -Istdio -DUSE_SCANSTACK -DPORT_ONLY   seterrno.c \
    | sed -e 's;^\(.*\)\.o[ ]*:;OBJ/i386-freebsd-cc/\1.o \1.d:;' > OBJ/i386-freebsd-cc/seterrno.d
    cc -M -DSCHILY_BUILD -IOBJ/i386-freebsd-cc -I../incs/i386-freebsd-cc -I../include -I/usr/local/include  -I/usr/local/include    -Istdio -DUSE_SCANSTACK -DPORT_ONLY   serrmsg.c \
    .....
    
    

    my pfsense-building.conf;

    
    export FREEBSD_VERSION=8
    export FREEBSD_BRANCH=RELENG_8_1
    export PFSENSETAG=RELENG_2_0
    export PFSPATCHFILE=/usr/home/pfsense/tools/builder_scripts/../builder_scripts/patches.RELENG_8_1
    export PFSPATCHDIR=/usr/home/pfsense/tools/builder_scripts/../patches/RELENG_8_1
    export SUPFILE=/usr/home/pfsense/tools/builder_scripts/../builder_scripts/RELENG_8_1-supfile
    export CUSTOM_COPY_LIST=/usr/home/pfsense/tools/builder_scripts/../builder_scripts/copy.list.RELEN
    # Comment out the following line if you would like to automatically select an update server.
    export OVERRIDE_FREEBSD_CVSUP_HOST=cvsup18.freebsd.org
    export BASE_DIR=/usr/home/pfsense/tools/builder_scripts/../..
    export BUILDER_TOOLS=/usr/home/pfsense/tools/builder_scripts/..
    export BUILDER_SCRIPTS=/usr/home/pfsense/tools/builder_scripts
    export EXTRA_DEVICES=siba_bwn,bwn,run
    export PFSPORTSFILE=buildports.RELENG_2_0
    #export PFSENSE_WITH_FULL_GIT_CHECKOUT="true"
    
    

    thank you for your help..


  • Rebel Alliance Developer Netgate

    We've been trying to track that down but there is an easy workaround,

    cd /usr/ports/sysutils/cdrtools;
    make install clean
    

    Then go back to doing the build



  • @jimp:

    We've been trying to track that down but there is an easy workaround,

    cd /usr/ports/sysutils/cdrtools;
    make install clean
    

    Then go back to doing the build

    Thank you @jimp


Log in to reply