Problems installing from live / memstick-snapshot



  • A couple of days ago I checked the dev-mailinglists to check if there was any news about the public snapshots, and there was news. I found the snapshots with each different dates (2012-01-21, 2012-01-19 and 2012-02-16) and I tried each of them, but all have the same problem. When you try to install the snapshot to the USB-stick (in my case an 8GB USB-3.0 stick) the installer at first glance seems fine, it runs and does it thing, but after a couple of minutes (~54%) the following error appears: 'Execution of command /usr/sbin/mtree -deU -f /etc/mtree/BSD.x11-4.dist -p /mnt/usr/X11R6 FAILED with a return of 1'.

    The last lines of the log file are:

    /usr/sbin/mtree -deU -f /etc/mtree/BSD.local.dist -p /mnt/usr/local
    >>> Exit status: 0
    /bin/mkdir -p /mnt/usr/X11R6
    >>> Exit status: 0
    /usr/sbin/mtree -deU -f /etc/mtree/BSD.11-4.dist -p /mnt/usr/X11R6
    >>> Exit status: 1
    

    Why the heck are you trying these snapshots anyway?
    Because FreeBSD 8.1 didn't support my new RTL8111E NIC with VLAN support. I also tried compiling the driver myself but without any luck. I have to replace the miibus with a newer version in order to run the new driver.

    What have you tried yourself?
    I replaced the storage medium, tested multiple USB-sticks and even different versions of the snapshots, but all give me the same error message.

    What kind of hardware are you using?
    Mainbord: Asrock H61M-ITX
    CPU: Intel Celeron G530
    RAM: 1x JM1333KLN-4G (4GB Transcend DDR3)
    PCI-E: Intel Gigabit CT Desktop Adapter (EAN: 0735858202169)

    (After checking the LiveCD snapshot ISO I can't find BSD.x11-4.dist anywhere, please tell me I'm missing something here. :))


  • Rebel Alliance Developer Netgate

    What exact file did you download?

    The mtree error I thought was only on the 9.x snapshot we tried (and abandoned, since we're now targeting 8.3). It can actually be ignored, it's safe to just keep going.



  • The RELENG9 snapshots from databeestje's server, tried every one of them except the 'Full-Update' because it isn't relevant in my situation. I didn't know you guys abandoned the 9.0-branch, now I feel stupid. I'm going to try the 8.3 snapshots and let you know when it works.

    PS: Thanks for the quick reply.


  • Rebel Alliance Developer Netgate

    We will be targeting 9.x for 2.2 but there were too many issues with it to work out for the timetable we have in mind for 2.1. There is a releng82 (and maybe 83?) folder on databeestje's server that are more current.



  • Sweet, just put one from the 8.3-branch on a USB-stick and I will check it out.

    PS: You're really fast. ;)

    Update:
    The 8.3 snapshots seems to do it, the only thing that doesn't work yet is USB 3.0 but that isn't important. I still got some spare USB 2.0 left.



  • I'll empty the releng9 dir on the server, they are stale



  • Thanks databeestje and jimp!

    The RLRENG8.3-branch is working fine, even IPv6 is up and running without any problems (had some configuration issues though). Thanks again.


Log in to reply