Cant get load balancing to work.



  • Okay so I have 2 seperate connections and running this through VMWare. I have set this up before so I am really out of ideas.

    So

    So - 1st connection is bound to WAN - 192.168.1.109 gateway 192.168.1.1
    OPT1 - 192.168.0.109 gateway 192.168.0.1

    and the LAN IP is 192.168.1.10 (on the same subnet as WAN. This is the first time I tried this I will be honest.)

    Status shows both are connected and online

    I think I remember having to setup defualt routes in windows? Is that so? I added the gateway to my third virtual NIC.

    Funny thing is.. When I go to speedtest.net, it shows ISP#1 in the bottom left corner. Refresh the page a million times; it never changes. BUT open up a new tab, go to whatismyip.com, it shows the IP address from ISP#2. So it seems like it's somewhat working, but I cannot actually perform a speedtest. Downloads do not function either.

    I have basically allowed everything for firewall rules as well..

    I wrote up a huge post and then accidentally shut the window and lost it all..So this is very brief as I don't feel like typing out every detail again :( If there are any questions about my setup I can respond within a few minutes!

    Added screenshots.

    Oh, in the command prompt screenshot, the interface 192.168.1.2 is the virtual adapter that connects to the VM 192.168.1.10. So that line basically says any traffic goes out of that 192.168.1.2 IP -> VMware LAN interface.








  • What you did is not a setup for LoadBalancing.

    Go to System -> Routes -> Groups
    Add both WAN connections, set both to Tier 1

    Add this Gateway Groupt as the Gateway in "Firewall -> Rules"


  • Rebel Alliance

    This is a Bad idea:

    and the LAN IP is 192.168.1.10 (on the same subnet as WAN. This is the first time I tried this I will be honest.)



  • @ptt:

    This is a Bad idea:

    and the LAN IP is 192.168.1.10 (on the same subnet as WAN. This is the first time I tried this I will be honest.)

    Any reason why? I am curious. The first time I setup pfsense successfully, the problem I was having is my actual networked devices at home would no longer be able to access network shares  or anything. I had to download my movie with pfsense at dual speeds..then turn off (or modify routing table) pfsense in order for my other devices to see the computer again. I played with the static routes but since it's all through virtual adapters it's much more confusing than if I had a dedicated PC running pfsense. I am not worried about people around me hacking me. Is that your concern? Other than that what would be an issue with this?

    And to the first post, THANK YOU! Will try it! It has been over a year and I am just rusty.

    Thanks so much for the help my bretheren



  • Also I do not see a groups option in system -> static routes

    Only the ability to add routes

    am I in the wrong place?

    Looking everywhere I don't see anything with Tier 1 or "groups" at all

    EDIT I am running a really old version of pfsense, even though I got it from the official site. I am upgrading to 2.0 as we speak which might fix a lot of issues.

    Thanks again my dudes.


  • Rebel Alliance

    The "latest stable" version of pfSense is 2.0.1

    In the Docs you will find info about Multi-WAN in 2.0 /2.0.1 http://doc.pfsense.org/index.php/Main_Page

    About WAN & LAN on same subnet:

    @podilarius:

    starting with the basic. All you WAN and LAN are in the same subnet. This is usually not a good idea.

    @cmb:

    Usually not a good idea is being kind. :) That simply will not work reliably with any software under any circumstance, don't do it.



  • In addition to what others noted, the fact you have multiple default gateways on Windows is going to lead to all kinds of "fun". Don't do that.



  • Removed all default routes from routing table in windows.

    In groups created a group and both WAN's are set to tier 1.

    Is there anything I need to do in Settings -> Routes -> Gateways? Besides for adding the second gateway? Do I uncheck the "default gateway" option?

    Added pfsense as default route. Internet connection is working, but still only using one internet connection. Speeds have not increased either.

    Anything else I need to do?



  • Okay so I realized how easy it was.

    Reverted back to version 1.3 since I started to remember things previously and had it configured within 3 minutes with approximately 5 clicks.

    I am now reaching speeds of 29mbit/sec on speedtest, and rapidshare it is peaking higher than that.

    Thanks for your help and patience!

    zsr


Log in to reply