Intel 1000 PT NIC will not get an IP address through DHCP



  • Hey everyone, I recently upgraded my PFsense 2.0 box with 2 new Intel PRO /1000 PT single port server adapters I purchased online, and I when I plug them directly into my cable modem, they do not register an IP address via DHCP. I checked to make sure dhcp client is enabled, I also installed my old D-LINK desktop NIC (DFE-530TX I believe) into an empty PCI slot and plugged the modem into that, and it picked up an IP right away. So I know for sure it's the NIC, but I can't get it going  :-\ Anyone ran into this issue before? I tried manually setting the duplex speed on the NICs as well, to no avail. If anyone could help that would be great. I also verified the NICs work fine in my desktop computer.

    I should also add, that when I refresh 192.168.1.1 my interface status randomly changes from autoselect (down red arrow) to 0.0.0.0 1000BASE-T, to just 1000BaseT speed, et c. Seems to be random as I refresh the page…Is it because these are server adapters? I also tried reinstalling PFsense thinking maybe it needed drivers during install, but getting the same issue.

    WAN -> em0 -> NONE (DHCP)

    Releasing and renewing on the status page also just assigns it 0.0.0.0 again. I hope this is enough info for someone to help. These NICs weren't cheap but I was experience down speed issues and decided to try upgrading from the random unknown NICs I had lying around to some high quality ones.


Log in to reply