Gitsync



  • ??

    Is there a branch or just "master" still?

    Tks!    :)



  • The master branch is still the work on 2.1 for now.  There probably won't be a 2.1 branch either until closer to its release or until it is released.



  • Thanks!    :)


  • Rebel Alliance Developer Netgate

    beware gitsync if you are on 2.0/2.0.1 binaries. There have been changes in the code recently that require updated binaries (PHP 5.3, etc).

    You can get some early snapshots from here:
    http://iserv.nl/files/pfsense/releng83/

    If you're on an image from this week or newer, then you can gitsync fine.



  • @jimp  I gitsync every couple of days or so… If i read this correctly, I should do a manual firmware update correct?


  • LAYER 8 Global Moderator

    I am curious on this as well - I am currently running

    2.1-DEVELOPMENT (i386)
    built on Fri Nov 25 17:45:38 EST 2011
    FreeBSD 8.1-RELEASE-p6

    And just gitsync'd a couple of days ago and had not issues that I saw?

    Should I update to these snapshots?
    http://iserv.nl/files/pfsense/releng83/

    I take it that will update from 8.1 to 8.3


  • Rebel Alliance Developer Netgate

    Yes, you will have to upgrade. You may not see issues yet (but you will if you try to change a password), but as time goes on it will be virtually guaranteed.

    Also some new options in the GUI and such require newer packages or ports.

    The new images are based on FreeBSD 8.3. We should have snapshots going again in a few days, at which point the gitsync process will again be more likely to break as time goes on.

    In many cases gitsync is safe, and it has been for a long time, but the closer we get to release we have to make more and more intrusive changes, which will likely fail on older binaries.


  • LAYER 8 Global Moderator

    Great info - thanks!

    Will update tonight when I am local.  Normally everything goes smooth and I have updated via remote before.  But clearly its safer to be local ;)



  • @johnpoz:

    Great info - thanks!

    Will update tonight when I am local.  Normally everything goes smooth and I have updated via remote before.  But clearly its safer to be local ;)

    Let me know how it turns out.. I probably can't update firmware until the weekend.. Its going to be a long process for me because I know I'll have to manually re-install binaries for some of the pfsense package (snort, squid to name a couple)

    @jimp Thank for the quick reply!


  • LAYER 8 Global Moderator

    that did not go well!!!  Ended up just doing a reinstall from the liveCD 2.1 version

    I tried this update
    pfSense-Full-Update-2.1-DEVELOPMENT-i386-20120227-2226.tgz

    didn't even update to 8.3 – some error a certs on line 591, filters would not load.  Could not get access to internet from any my machines.  Just ended up doing a clean install from
    pfSense-LiveCD-2.1-DEVELOPMENT-i386-20120227-2026.iso

    shoot can not even get unbound to run..  Guess I should of put this off til the weekend when I have more time to play.  Now running with limping along system..

    PHP Errors:
    [29-Feb-2012 03:41:36 UTC] PHP Fatal error:  Call to undefined function unbound_get_next_id() in /usr/local/www/unbound_acls.php on line 61



  • Ran into the same problem as johnpoz.
    Upgraded "2.1-DEVELOPMENT (i386) built on Sun Sep 11 21:36:53 EDT 2011" using "pfSense-Full-Update-2.1-DEVELOPMENT-i386-20120226-0110".
    Upgrade completed, rebooted, showed error about certs and did not continue booting.
    Rolled back a snapshot (vmware is useful for things like that!) and continued using 'old' version.



  • thanks for sharing your feedback guys!! I will wait on updating the firmware :-(


  • Rebel Alliance Developer Netgate

    I'm running an image from the 27th on my home router and had no errors or issues to speak of.

    If you can upgrade and give the exact full error (in a new thread) then we can look into it.

    Unbound errors should probably be reported in the package forum, not in the 2.1 board though. Trying to reproduce the problem without unbound would also help.



  • @jimp:

    I'm running an image from the 27th on my home router and had no errors or issues to speak of.

    If you can upgrade and give the exact full error (in a new thread) then we can look into it.

    Unbound errors should probably be reported in the package forum, not in the 2.1 board though. Trying to reproduce the problem without unbound would also help.

    jimp, did you upgrade or a full re-install?


  • Rebel Alliance Developer Netgate

    Upgrade (Full install)


  • LAYER 8 Global Moderator

    Don't really want to go back and try and upgrade again.  Currently it seems to be running fine, just need add some packages and get my ipv6 setup again and i will be happy ;)

    See this error now when trying to gitsync

    ===> Running /etc/rc.php_ini_setup…
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20090626/xmlreader.so' - /usr/local/lib/php/20090626/xmlreader.so: Undefined symbol "dom_node_class_entry" in Unknown on line 0



  • Not exactly an error, just a warning.  If the code that uses that module was currently activated in pfSense, it would fail to load your configuration after that.


  • LAYER 8 Global Moderator

    Never said that before - so how do I make it go away?



  • I tried an upgrade yesterday and it did not go smooth. I ended doing a full install of 2.0.1, gitsync then did a restore from a full tar backup… I wish I could show the errors I had but my dumba$$ didn't save the txt file and my computer decided to restart over night for windows updates. From memory, there were alot of PHP errors for old syntax. Mostly from packages tho. My vlan interface wouldnt come up because there was no altq driver. UPNP wouldn't start, really wish i had the logs for that.  I thought of just doing a full install of 2.1 but because of the UPNP errors, I didnt' want to try it.


  • Rebel Alliance Developer Netgate

    If you try it again, start a new thread with the errors.

    I would still expect packages to be problematic because there are likely lots of them out there that need updates for depreciated code (though that isn't fatal in most cases).

    Time to close out this thread since it's strayed way too far from the original topic.


Log in to reply