[SOLVED]PPPoE is not working after changing network card!


  • Hi all,

    I have an ITX server with 3 NICs.

    1. Realtek 8111E (original with motherboard)
      2&3. Intel Dual Port Card (Installed on PCI)

    The PF is running under VMware workstation and I assigned two NICs as WAN and LAN.
    Realtek 8111E –> VMnet0 --> WAN
    Intel Port #1 --> VMnet3 --> LAN
    I read the PF doc about how to set up the PF in VM and it was working for around 6 months.
    (http://doc.pfsense.org/index.php/Installing_pfSense_in_VMware_under_Windows)
    Intel Port #2 is using to access the VM host machine from VNC.

    Yesterday I changed the NIC assignment as followed:
    Intel Port #2 --> VMnet0 --> WAN
    Intel Port #1 --> VMnet3 --> LAN
    Realtek 8111E is using to access the VM host machine from VNC.

    Now the problem is I can reach the LAN and configure PF through web configuration.
    But I can’t let PPPoE working properly.
    The log in PPP shows that it’s always trying to connect, but failed.
    I tried to reset the PPPoE connection and restart the PF/VM/host PC, no progress.
    I tested the upstream Internet modem, it’s working fine.

    I will appreciated for any reply!

    Zlyzwy


  • Are you running pfSense 2.0.x?

    Where does ppp come into the situation (which hardware port does it run on)? I SUSPECT your WAN link should really be pppoe0 and pppoe0 should be using Intel port #2? You have misconfigured if (for example) your WAN is em1 AND pppoe is using em1


  • First I would like to thanks for any reply and help!

    Are you running pfSense 2.0.x?

    I am running latest PF 2.0.1.

    Where does ppp come into the situation (which hardware port does it run on)? I SUSPECT your WAN link should really be pppoe0 and pppoe0 should be using Intel port #2? You have misconfigured if (for example) your WAN is em1 AND pppoe is using em1

    I am now away from my PF box but as I remember there are the following assign port:
    1. em0(WAN) –> with MAC
    2. em1(LAN)  --> with MAC
    3. PPTP --> Not sure
    4. PPPoE0(em0) --> with account
    5. PPPoE1(PPPoE) --> with account

    I agreed that there may some misconfigure on the assign port, so I used Setup Winzard to generate a new PPPoE connection, that's why you can see the PPPoE1(PPPoE) in port list.

    I will tired to get more detail information from my PF box. But if you may teach me how to reset the WAN interface, that will be great appreciated.


  • Which interface (or interfaces?) are connected to systems that talk PPP?


  • @wallabybob:

    Which interface (or interfaces?) are connected to systems that talk PPP?

    Intel Port #2 –> VMnet0 --> WAN?
    Intel Port #2 is the physical NIC which recongized by host PC (windows 2003 server). And it's connecting to the PPPoE modem.
    VMnet0 is the name in Virtual Network Editor. I bridge the VMnet0 on Intel Port #2.

    Thanks.


  • I don't what is hidden in the VMware components. If you were running this on physical NICs your Interfaces -> (assign) page should show Interface=WAN, Network Port=PPPOE0 and Interfaces -> (assign), click on  PPPs tab should show Interface=pppoe0, Interfaces(s) Port(s)=name and back on the Interfaces -> (assign) page Interface=name should have a Network Port of (Intel port #2), probably em1

    pfSense WAN interface should be a PPPoE interface and that PPPoE interface should use physical interface "Intel port #2" (which is probably known to pfsense as something like em1. You don't appear to have the correct hierarchy because your WAN interface goes directly to the physical interface, bypassing PPP.

    Maybe you have come to this state because you haven't added the PPPoe interface to the pfSense interface pool by clicking the "+" on the Interfaces -> (assign) page. If you are unsure, please post a screenshot of that page.


  • Problem SOLVED!!!:)

    I removed all VMnet0 and VMnet3 from VM Network Editor. then add these NICs again… everything goes fine...

    I didn't know why but it's now working fine.

    BTW, I am using VM Workstation 8.0.2..

    Thanks a lot~


  • @zlyzwy:

    I removed all VMnet0 and VMnet3 from VM Network Editor. then add these NICs again… everything goes fine...

    Is that all you did?

    You still have pfSense WAN as the "raw" NIC and not pppoe0?


  • @wallabybob:

    @zlyzwy:

    I removed all VMnet0 and VMnet3 from VM Network Editor. then add these NICs again… everything goes fine...

    Is that all you did?

    You still have pfSense WAN as the "raw" NIC and not pppoe0?

    I think I didn't need to change anything in PF.
    Here is my setting in Network interface.



    ![network ports.jpg_thumb](/public/imported_attachments/1/network ports.jpg_thumb)
    ![network ports.jpg](/public/imported_attachments/1/network ports.jpg)


  • Thanks, the screenshots look good. The earlier replies suggested you were mapping pfSense WAN directly to the NIC (not a pppoe interface) and you didn't say you changed that.