Ssh port 22 unusable (realy slow)



  • Hi,

    Since 2 days we have a strange problem when sending a small fall (160kb) over ssh. We sent a small file each night to an external server over ssh (with script). Since a 2 days this doesn't work anymore.
    today i tried connection manually to that server and the connections works fine. But when i try to sent a file it tries and then it retries …. When i look at the server i can see a file of 0 bytes.
    I tried winscp and i get a transfer speed of 1.6bytes /s ??and after a few seconds host closed connections retry ...

    tried it from 2 other locations ( one behind pfsense) and that works fine.

    I am pretty sure the rules on the firewall are fine ?

    Any suggestions ??

    thanks in advance



  • This may not be very helpful but, what makes you think pfSense is the cause of your problem?  Since your manual transfer worked wouldn't that tell you your problem lies elsewhere?



  • The manual transfer was from anohter location … but i will go at the client this week



  • Try to narrow it down more within the same site, different source host, different scp application, etc. It may be general connectivity issues between those two particular points of the Internet, if you can try a different means of file or other transfer to compare that's helpful.



  • And if it's possible and if you haven't already tried it, try a) testing with pfSense configured to pass everything and/or b) try testing with the pfSense box completely out of your network.  It may provide some insight.  Also, I've become a big fan of the built in packet capture tool (also Wireshark) but you're on your own with those.



  • Hi,

    I have allready tried from a different host in the same network, same result … and also tried with any any in the firewall setup but the result stays the same.

    Today i did a final test: setup an ssh server at home and tried a connection from the client to my home over ssh and that gave zero problems ...

    So it seems the problem is between the two sites ....

    But i will give it a try at the client with a pc connected straight to the cable modem just to be sure ...



  • There was no problem with the line … did a new installation from 2.0 to 2.01 and everything was ok again ??


Log in to reply