Pantech UML290



  • I am trying to get a Verizon 4G connection working, and having no luck. This link would imply that it "just works":
    http://doc.pfsense.org/index.php/Verizon_UML290

    I assigned my ppp interface to the device cuaU0, although ls /dev/cu* shows a couple other devices - which are not available in the ppp config page.

    When I try to connect I just get this in my ppp log:

    Feb 24 23:28:19	ppp: [opt3_link0] chat: Detected Hayes compatible modem.
    Feb 24 23:28:19	ppp: [opt3_link0] chat: Dialing server at *99***3#...
    Feb 24 23:28:19	ppp: [opt3_link0] chat: The remote modem did not answer.
    Feb 24 23:28:19	ppp: [opt3_link0] MODEM: chat script failed
    Feb 24 23:28:19	ppp: [opt3_link0] Link: DOWN event
    Feb 24 23:28:19	ppp: [opt3_link0] LCP: Down event
    Feb 24 23:28:19	ppp: [opt3_link0] Link: reconnection attempt 4 in 2 seconds
    

    I found this http://ubuntuforums.org/showthread.php?s=274f1bef08b7833c32a7a393c9068f92&t=1665287&page=2 showing different logins used for 3G vs 4G, I do not currently have 4G coverage, so I also tried connecting with the #777 dial string - any ideas?



  • i had a feeling - had to hard set the modem to 3G for it to work, apparently theres no facility for auto-detecting the network.

    Use the Pantech Modem Utility to hard code 3G in to the firmware - per this article:

    http://www.evdoinfo.com/content/view/3492/64/

    and used #777 as the dial string - will hunt for a 4G tower to verify that.



  • My UML290 works fine without changing anything on 4G, though from the sounds of it you don't have 4G coverage, which is probably why. I know that card has similar requirements on other routers with connectivity where no 4G exists.


Log in to reply