Autodect proxy settings & wpad not working on some iexplorer running Windows 7



  • Hi there.

    I have setup pfsense 2.0.1 to serve a wpad file to all web client browsers (using DNS Forwarder)
    The weird thing is that some Windows 7 clients are unable to read this pac file but many others can within the same LAN.

    In the other hand, I cannot make iphones nor Adroid phones to get this wap file.

    Any help appreciated.
    Regards,
    Jesus.



  • Did you tried configuring dhcp options too?



  • I did, but I don't know with option is righ. Let me explain:

    I'll show you the options I have set in DHCP Server settings for LAN Interface:

    Tried the following:
    Number: 252
    Type: Text
    Value: http://wpad.mydomain/proxy.pac

    Also tried:
    Number: 252
    Type: String
    Value: "http://wpad.mydomain/proxy.pac"

    Note: String type need pac file enclosed by ""

    None of them have worked for me.

    In both settings, DNS Forwarder has an entry for wpad.mydomain bound to a valid (and reachable) IP in the intranet.
    Typing http://wpad.mydomain/proxy.pac in a browser returns the file proxy.pac for download.

    Regards,
    Jesus



  • Hi there.

    I read in some posts that the Web Server needs this extension (.dat) be set to "application/x-ns-proxy-autoconfig".

    Would it be necessary to set this mime type in pfsense for wpad.dat file?

    Thank you,
    Jesus



  • The .dat/wpad/pac file is a javascript.

    If javascript fails, then autodetect will not work.

    If you can download the file from webserver, then it's working.



  • Thank you very much for your help.

    Any idea about how to get this working?

    I can download the file wpad.dat from an Android phone, but the DHCP 252 option seems not be working on this android phone.

    Thank you very much in advance.
    Jesus.


Log in to reply