• I have WAN and LAN bridged with a "maintenance" port.   This seems to happen after a reboot and has followed for the last three or four updates.  Started when I put the snap based on 9.0 but continues with 8.3

    Gateway shows 100% loss and down until I hit "save" on interfaces/Bridge

    Im gonna blow it up and start fresh but wanted to put it here as a report just in case.   Its just the test box.

    Feb 28 20:16:44 kernel: arpresolve: can't allocate llinfo for 172.31.125.1
    Feb 28 20:16:45 kernel: arpresolve: can't allocate llinfo for 172.31.125.1
    Feb 28 20:16:46 kernel: arpresolve: can't allocate llinfo for 172.31.125.1
    Feb 28 20:16:46 check_reload_status: Syncing firewall
    Feb 28 20:16:47 kernel: arpresolve: can't allocate llinfo for 172.31.125.1
    Feb 28 20:16:48 kernel: arpresolve: can't allocate llinfo for 172.31.125.1
    Feb 28 20:16:49 kernel: arpresolve: can't allocate llinfo for 172.31.125.1
    Feb 28 20:16:49 php: /interfaces.php: Calling interface down for interface opt2, destroy is
    Feb 28 20:16:49 php: /interfaces.php: Deny router advertisements for interface opt2
    Feb 28 20:16:49 php: /interfaces.php: ROUTING: setting default route to 172.31.125.1
    Feb 28 20:16:50 apinger: alarm canceled: BridgeGW(172.31.125.1) *** down ***
    Feb 28 20:16:51 dnsmasq[63075]: exiting on receipt of SIGTERM
    Feb 28 20:16:52 dnsmasq[12861]: started, version 2.55 cachesize 10000
    Feb 28 20:16:52 dnsmasq[12861]: compile time options: IPv6 GNU-getopt no-DBus I18N DHCP TFTP
    Feb 28 20:16:52 dnsmasq[12861]: reading /etc/resolv.conf
    Feb 28 20:16:52 dnsmasq[12861]: using nameserver 172.31.125.1#53
    Feb 28 20:16:52 dnsmasq[12861]: using nameserver x.x.x.x#53
    Feb 28 20:16:52 dnsmasq[12861]: using nameserver 8.8.8.8#53
    Feb 28 20:16:52 dnsmasq[12861]: using nameserver 2x.x.x.x0#53
    Feb 28 20:16:52 dnsmasq[12861]: read /etc/hosts - 2 addresses
    Feb 28 20:16:54 dhcpd: Internet Systems Consortium DHCP Server 4.2.3
    Feb 28 20:16:54 dhcpd: Copyright 2004-2011 Internet Systems Consortium.
    Feb 28 20:16:54 dhcpd: All rights reserved.
    Feb 28 20:16:54 dhcpd: For info, please visit https://www.isc.org/software/dhcp/
    Feb 28 20:16:55 check_reload_status: updating dyndns opt2
    Feb 28 20:16:57 apinger: Exiting on signal 15.
    Feb 28 20:16:57 check_reload_status: Reloading filter
    Feb 28 20:16:58 check_reload_status: Reloading filter
    Feb 28 20:16:58 apinger: Starting Alarm Pinger, apinger(17067)
    Feb 28 20:16:58 php: /interfaces.php: Creating rrd update script
    Feb 28 20:17:58 apinger: Error while feeding rrdtool: Broken pipe

    :)


  • Running-

    2.1-DEVELOPMENT (i386)
    built on Mon Feb 27 22:30:02 CET 2012
    FreeBSD 8.3-PRERELEASE


  • "arpresolve: can't allocate llinfo" generally means you're trying to ARP something that isn't on a locally connected subnet. What's ifconfig look like before and after you hit save?


  • Before

    $ ifconfig
    rl0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3808 <vlan_mtu,wol_ucast,wol_mcast,wol_magic>ether 00:18:4d:f0:9a:f6
    	inet6 fe80::218:4dff:fef0:9af6%rl0 prefixlen 64 scopeid 0x1 
    	nd6 options=41 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    sk0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=80008 <vlan_mtu,linkstate>ether 00:21:91:1f:dc:ef
    	inet6 fe80::221:91ff:fe1f:dcef%sk0 prefixlen 64 scopeid 0x2 
    	nd6 options=41 <performnud>media: Ethernet autoselect (none)
    	status: no carrier
    vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=82808 <vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:07:95:fe:b5:79
    	inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
    	inet6 fe80::207:95ff:fefe:b579%vr0 prefixlen 64 scopeid 0x6 
    	nd6 options=41 <performnud>media: Ethernet autoselect (none)
    	status: no carrier
    plip0: flags=8810 <pointopoint,simplex,multicast>metric 0 mtu 1500
    enc0: flags=0<> metric 0 mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    	options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000 
    	inet6 ::1 prefixlen 128 
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9 
    	nd6 options=43 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
    	syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	ether 00:0d:56:0c:8d:5c
    	inet 172.31.125.98 netmask 0xffffff00 broadcast 172.31.125.255
    	id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    	maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
    	root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
    	member: sk0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 2 priority 128 path cost 55
    	member: rl0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 1 priority 128 path cost 55</learning,discover,autoedge,autoptp></learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast></promisc></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></pointopoint,simplex,multicast></performnud></vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></performnud></vlan_mtu,linkstate></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud></vlan_mtu,wol_ucast,wol_mcast,wol_magic></up,broadcast,running,promisc,simplex,multicast> 
    

    After

    
    $ ifconfig
    rl0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=3808 <vlan_mtu,wol_ucast,wol_mcast,wol_magic>ether 00:18:4d:f0:9a:f6
    	inet6 fe80::218:4dff:fef0:9af6%rl0 prefixlen 64 scopeid 0x1 
    	nd6 options=41 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
    	status: active
    sk0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    	options=80008 <vlan_mtu,linkstate>ether 00:21:91:1f:dc:ef
    	inet6 fe80::221:91ff:fe1f:dcef%sk0 prefixlen 64 scopeid 0x2 
    	nd6 options=41 <performnud>media: Ethernet autoselect (none)
    	status: no carrier
    vr0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=82808 <vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:07:95:fe:b5:79
    	inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
    	inet6 fe80::207:95ff:fefe:b579%vr0 prefixlen 64 scopeid 0x6 
    	nd6 options=41 <performnud>media: Ethernet autoselect (none)
    	status: no carrier
    plip0: flags=8810 <pointopoint,simplex,multicast>metric 0 mtu 1500
    enc0: flags=0<> metric 0 mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    	options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000 
    	inet6 ::1 prefixlen 128 
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9 
    	nd6 options=43 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
    	syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	ether 00:0d:56:0c:8d:5c
    	inet 172.31.125.98 netmask 0xffffff00 broadcast 172.31.125.255
    	id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    	maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
    	root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
    	member: sk0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 2 priority 128 path cost 55
    	member: rl0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 1 priority 128 path cost 55</learning,discover,autoedge,autoptp></learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast></promisc></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></pointopoint,simplex,multicast></performnud></vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></performnud></vlan_mtu,linkstate></up,broadcast,running,promisc,simplex,multicast></full-duplex></performnud></vlan_mtu,wol_ucast,wol_mcast,wol_magic></up,broadcast,running,promisc,simplex,multicast> 
    

  • Even after blowing this up and starting over from scratch this still happens…    Fresh install. Fresh Config no config file import.

    2.1-DEVELOPMENT (i386)
    built on Wed Mar 21 14:05:45 CET 2012
    FreeBSD 8.3-RC1

    3 physical interfaces

    WAN Firewall rule allowing only 443.

    Outbound  Firewall rule allowing all.

    LAN-  Natted with firewall rule allowing all.        (192.168.15.1)

    and a Bridge interface between WAN and Outbound  -  BRG Firewall rule allowing all.  (172.31.125.98)

    I have to go to the BRG interface at "Interfaces/BRG" and hit "Save" before the gateway will show as "Up" on the dashboard, after a reboot.  GUI is highly unresponsive from the Outbound and WAN  interfaces till then though will respond intermittently.


  • Heres the config.  Its just a test box in the lab.

    
     <pfsense><version>8.3</version>
    	 <lastchange><theme>pfsense_ng</theme>
    	 <sysctl><tunable>debug.pfftpproxy</tunable>
    			<value>default</value> 
    		 <tunable>vfs.read_max</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.portrange.first</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.blackhole</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.udp.blackhole</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.random_id</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.drop_synfin</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.redirect</tunable>
    			<value>default</value> 
    		 <tunable>net.inet6.ip6.redirect</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.syncookies</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.recvspace</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.sendspace</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.fastforwarding</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.delayed_ack</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.udp.maxdgram</tunable>
    			<value>default</value> 
    		 <tunable>net.link.bridge.pfil_onlyip</tunable>
    			<value>default</value> 
    		 <tunable>net.link.bridge.pfil_member</tunable>
    			<value>default</value> 
    		 <tunable>net.link.bridge.pfil_bridge</tunable>
    			<value>1</value> 
    		 <tunable>net.link.tap.user_open</tunable>
    			<value>default</value> 
    		 <tunable>kern.randompid</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.ip.intr_queue_maxlen</tunable>
    			<value>default</value> 
    		 <tunable>hw.syscons.kbd_reboot</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.inflight.enable</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.log_debug</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.icmp.icmplim</tunable>
    			<value>default</value> 
    		 <tunable>net.inet.tcp.tso</tunable>
    			<value>default</value> 
    		 <tunable>kern.ipc.maxsockbuf</tunable>
    			<value>default</value></sysctl> 
    	 <system><optimization>normal</optimization>
    		<hostname>pfsense</hostname>
    		<domain>localdomain</domain>
    		 <group><name>all</name>
    
    			<scope>system</scope>
    			<gid>1998</gid>
    			<member>0</member></group> 
    		 <group><name>admins</name>
    
    			<scope>system</scope>
    			<gid>1999</gid>
    			<member>0</member>
    			<priv>page-all</priv></group> 
    		 <user><name>admin</name>
    
    			<scope>system</scope>
    			<groupname>admins</groupname>
    			<password>$1$dSJImFph$GvZ7.1UbuWu.Yb8etC0re.</password>
    			<uid>0</uid>
    			<priv>user-shell-access</priv></user> 
    		<nextuid>2000</nextuid>
    		<nextgid>2000</nextgid>
    		<timezone>America/Vancouver</timezone>
    		 <time-update-interval><timeservers>0.pfsense.pool.ntp.org</timeservers>
    		 <webgui><protocol>https</protocol>
    			<ssl-certref>4f5d66a5edb2a</ssl-certref>
    			 <port><max_procs>2</max_procs></port></webgui> 
    		<disablenatreflection>yes</disablenatreflection>
    		 <disablesegmentationoffloading><disablelargereceiveoffloading><dns1gwint>opt1</dns1gwint>
    		<dns2gwint>opt1</dns2gwint>
    		<dns3gwint>none</dns3gwint>
    		<dns4gwint>none</dns4gwint>
    		<enablesshd>enabled</enablesshd>
    		 <firmware><allowinvalidsig><alturl><enable><firmwareurl>http://updates.pfsense.org/_updaters</firmwareurl></enable></alturl></allowinvalidsig></firmware> 
    		 <gitsync><repositoryurl><branch></branch></repositoryurl></gitsync> 
    		<language>en_US</language>
    		<dns1gw>BRGGW</dns1gw>
    		<dns2gw>BRGGW</dns2gw>
    		<dns3gw>BRGGW</dns3gw>
    		<dns4gw>none</dns4gw>
    		 <dnslocalhost><dnsserver>8.8.4.4</dnsserver>
    		<dnsserver>8.8.8.8</dnsserver>
    		<dnsserver>172.31.125.1</dnsserver></dnslocalhost></disablelargereceiveoffloading></disablesegmentationoffloading></time-update-interval></system> 
    	 <interfaces><wan><enable><if>rl0</if>
    
    			 <alias-address><alias-subnet>32</alias-subnet>
    			 <spoofmac></spoofmac></alias-address></enable></wan> 
    		 <lan><enable><if>vr0</if>
    			<ipaddr>192.168.15.1</ipaddr>
    			<subnet>24</subnet>
    			 <media><mediaopt></mediaopt></media></enable></lan> 
    		 <opt1><if>bridge0</if>
    			 <enable><spoofmac>00:0d:56:0c:8d:5d</spoofmac>
    			 <alias-address><alias-subnet>32</alias-subnet>
    			<ipaddr>172.31.125.98</ipaddr>
    			<subnet>24</subnet>
    			<gateway>BRGGW</gateway></alias-address></enable></opt1> 
    		 <opt2><if>sk0</if>
    			 <enable><spoofmac></spoofmac></enable></opt2></interfaces> 
    	 <staticroutes><dhcpd><lan><enable><range><from>192.168.15.201</from>
    				<to>192.168.15.230</to></range></enable></lan></dhcpd> 
    	 <pptpd><mode><redir><localip></localip></redir></mode></pptpd> 
    	 <dnsmasq><enable></enable></dnsmasq> 
    	 <snmpd><syslocation><syscontact><rocommunity>public</rocommunity></syscontact></syslocation></snmpd> 
    	 <diag><ipv6nat></ipv6nat></diag> 
    	 <bridge><syslog><nat><ipsecpassthru><enable></enable></ipsecpassthru> 
    		 <advancedoutbound><rule><source>
    					<network>192.168.15.0/24</network>
    
    				 <sourceport><descr><target><targetip><targetip_subnet>0</targetip_subnet>
    				<interface>opt1</interface>
    				 <poolopts><destination><any></any></destination></poolopts></targetip></target></descr></sourceport></rule> 
    			 <enable></enable></advancedoutbound></nat> 
    	 <filter><rule><id><type>pass</type>
    			<interface>wan</interface>
    			<ipprotocol>inet</ipprotocol>
    			 <tag><tagged><max><max-src-nodes><max-src-conn><max-src-states><statetimeout><statetype>keep state</statetype>
    			 <os><protocol>tcp</protocol>
    			<source>
    				 <any><destination><any><port>443</port></any></destination></any></os></statetimeout></max-src-states></max-src-conn></max-src-nodes></max></tagged></tag></id></rule> 
    		 <rule><type>pass</type>
    
    			<interface>lan</interface>
    			<source>
    				<network>lan</network>
    
    			 <destination><any></any></destination></rule> 
    		 <rule><id><type>pass</type>
    			<interface>opt1</interface>
    			<ipprotocol>inet</ipprotocol>
    			 <tag><tagged><max><max-src-nodes><max-src-conn><max-src-states><statetimeout><statetype>keep state</statetype>
    			 <os><source>
    				 <any><destination><any></any></destination></any></os></statetimeout></max-src-states></max-src-conn></max-src-nodes></max></tagged></tag></id></rule> 
    		 <rule><id><type>pass</type>
    			<interface>opt2</interface>
    			<ipprotocol>inet</ipprotocol>
    			 <tag><tagged><max><max-src-nodes><max-src-conn><max-src-states><statetimeout><statetype>keep state</statetype>
    			 <os><source>
    				 <any><destination><any></any></destination></any></os></statetimeout></max-src-states></max-src-conn></max-src-nodes></max></tagged></tag></id></rule></filter> 
    	 <shaper><ipsec><preferoldsa></preferoldsa></ipsec> 
    	 <aliases><proxyarp><cron><minute>0</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 newsyslog 
    		 <minute>1,31</minute>
    			<hour>0-5</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 adjkerntz -a 
    		 <minute>1</minute>
    			<hour>3</hour>
    			<mday>1</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /etc/rc.update_bogons.sh 
    		 <minute>*/60</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 sshlockout 
    		 <minute>1</minute>
    			<hour>1</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /etc/rc.dyndns.update 
    		 <minute>*/60</minute>
    			<hour>*</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /usr/local/sbin/expiretable -v -t 3600 virusprot 
    		 <minute>30</minute>
    			<hour>12</hour>
    			<mday>*</mday>
    			<month>*</month>
    			<wday>*</wday>
    			<who>root</who>
    			<command></command>/usr/bin/nice -n20 /etc/rc.update_urltables</cron> 
    	 <wol><rrd><enable></enable></rrd> 
    	 <load_balancer><monitor_type><name>ICMP</name>
    			<type>icmp</type></monitor_type> 
    		 <monitor_type><name>TCP</name>
    			<type>tcp</type></monitor_type> 
    		 <monitor_type><name>HTTP</name>
    			<type>http</type>
    
    			 <options><path>/</path>
    				 <host>`200`</host></options></monitor_type> 
    		 <monitor_type><name>HTTPS</name>
    			<type>https</type>
    
    			 <options><path>/</path>
    				 <host>`200`</host></options></monitor_type> 
    		 <monitor_type><name>SMTP</name>
    			<type>send</type>
    
    			 <options><send>EHLO nosuchhost</send>
    				<expect>250-</expect></options></monitor_type></load_balancer> 
    	 <widgets><sequence>system_information-container:col1:show,captive_portal_status-container:col1:close,carp_status-container:col1:close,cpu_graphs-container:col1:close,gmirror_status-container:col1:close,installed_packages-container:col1:close,interface_statistics-container:col1:close,interfaces-container:col2:show,ipsec-container:col2:close,load_balancer_status-container:col2:close,picture-container:col2:close,rss-container:col2:close,services_status-container:col2:close,traffic_graphs-container:col2:close,openvpn-container:col2:none,wake_on_lan-container:col2:none,gateways-container:col2:show,log-container:col3:show</sequence>
    		<filterlogentries>15</filterlogentries></widgets> 
    	 <revision><time>1332441708</time>
    
    		<username>admin@172.31.125.63</username></revision> 
    	 <openvpn><l7shaper><container></container></l7shaper> 
    	 <dnshaper><cert><refid>4f5d66a5edb2a</refid>
    
    		<crt>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</crt>
    		<prv>R2VuZXJhdGluZyBSU0EgcHJpdmF0ZSBrZXksIDEwMjQgYml0IGxvbmcgbW9kdWx1cwouLi4rKysrKysKLi4uKysrKysrCnVuYWJsZSB0byB3cml0ZSAncmFuZG9tIHN0YXRlJwplIGlzIDY1NTM3ICgweDEwMDAxKQotLS0tLUJFR0lOIFJTQSBQUklWQVRFIEtFWS0tLS0tCk1JSUNYZ0lCQUFLQmdRREpPYWJzNlR5dGVNTUFJN01YVmtXVWpUc3NaR0VjQllaQ2pXWFVBSjUrUys3VXJjejgKV0NyeFB6a2JOZXJPR3BJWk1WV1FhNkFQUEZJcEc2U0dhQm5ZVEp2c1M4SEREV0szOFZhOGdnRExrWHQ1RFlxUQpsZUNCSkIxUG4yNVlkVmRGejdJYnlLVm16QmVwU2d4WVBSOUYyK1BEOFFaMTQ2VDVJUkpnNVY5aVR3SURBUUFCCkFvR0JBSWJNQmhSaVVmRnJHa1gzcERzWDRkaVhtM0lyZEJvUFlWY24zWFRkVFU4Umt0WUo3MjJEcXBDZFo2WGcKd29CNnNEQU1LbU5xbFhoZlVqS1RmKzFCd3owLzhnaXdSbS9EWWJzYXVPMmNsaEtBWlhzTmQyL2ZtTmp4WmhYQQpkaE9HTnZEeXFHZ2hOUDZsWHhCaTdObURoNjVhK21WK1NxM0ZBMFpEakM0d0hXV0JBa0VBN2xFMEhmam0yQmdBCit0aHREa0syWjBQUTVNSEZCZ2NucmRoZzlOVDZPdWVMVFFVbmlJTmVGQzV3MjRtWk8yUkVMSjRldnd6c0R1R3MKRXBFdm1IQXlyd0pCQU5nbjVGcWVwMm53U0RiemNlZk8xY245MXBUaE5WSldiOEpLUVZsbExkL2dLNGhTN1l3RApZdU8wYlNzNU5tZFFiTldhRGZjMURRdStwdVlGcDZ2cU1tRUNRRHR6ZkhuaHBzelBxQ2JycU1EKytYdm5XZ3hICkhueHplbjJPMWhrZHJGTFhnbE96Ym5wS3MwUjdsV0hmQUovbFVuQ0MvWTZSamEza3RFVnBmS01ka2pjQ1FRQ3AKcklhLzY1SVd3cHF0SitQZHhxcGk2SEtzWXl2citoVzRPWG1hcHFXZit1T3hHd2VFeEpPM2trV3ZqRFY4VzlGUwp5cDd6MGh6dmZ6U2Jrd3pQRWdPQkFrRUFveCttaW5ibVpmUGlQR2hwelc1cEtjbGVqMmw4eVNrM2ZITlBFcWlvClBKdVFiNXRiSmljSm9BRUJhSEphMGM0K0REZ0RQbW5YcTBBZ1FDaHZuZHdnVmc9PQotLS0tLUVORCBSU0EgUFJJVkFURSBLRVktLS0tLQo=</prv></cert> 
    	 <installedpackages><tab><menu>
    		 <service><package><name>widescreen</name>
    
    			 <website><pkginfolink><category>Enhancements</category>
    			<version>0.2</version>
    			<status>BETA</status>
    			<required_version>2.0</required_version>
    			<maintainer>ey@tm-k.com</maintainer>
    			<config_file>http://www.pfsense.org/packages/config/widescreen/widescreen.xml</config_file>
    			<configurationfile>widescreen.xml</configurationfile></pkginfolink></website></package> 
    
    	 <ppps><gateways><gateway_item><interface>opt1</interface>
    			<gateway>172.31.125.1</gateway>
    			<name>BRGGW</name>
    			<weight>1</weight>
    			 <interval><descr><defaultgw></defaultgw></descr></interval></gateway_item></gateways> 
    	 <bridges><bridged><members>wan,opt2</members>
    			 <descr><maxaddr><timeout><maxage><fwdelay><hellotime><priority><proto>rstp</proto>
    			 <holdcount><ifpriority><ifpathcost><bridgeif>bridge0</bridgeif></ifpathcost></ifpriority></holdcount></priority></hellotime></fwdelay></maxage></timeout></maxaddr></descr></bridged></bridges></ppps></service> </menu></tab></installedpackages></dnshaper></openvpn></wol></proxyarp></aliases></shaper></syslog></bridge></staticroutes></lastchange></pfsense> 
    


  • Played with this a little more tonight.    :P

    2.1-DEVELOPMENT (i386)
    built on Wed Apr 18 18:25:03 EDT 2012
    FreeBSD 8.3-RELEASE

    Tried using "Save" on the physical interfaces to see if the gateway would show as live on the dashboard but until I click "save" on the "Bridge" interface it stays offline.

    From the Bridge interface I clicked "or add a new one"  (Gateway)

    added 172.31.125.98    (this boxes bridge address)

    Went to System/Routing.  The 172.31.125.1 gateway was no longer (just .98 was) there but still showed up as an option on the Bridge Interface even though I would pick it, it would not survive the save.

    Went back to Routing and deleted the 172.31.125.98 gateway and the 172.31.125.1 gateway then showed up. Clicked Default and save.

    Back to Bridge Interface…   Gateway shows none.  Select 172.31.125.1 and Save.

    Dashboard "Gateway" shows as Online.

    Reboot.

    Dashboard "Gateway" shows as Offline.

    Go back to Interfaces "Bridge"  click "Save" to get it to show up as online.

    Im accessing this box the entire time through its "WAN" interface.

    172.31.125.98
                                                                  l
                                                 WAN       Bridge        Opt1
    172.31.125.0/24 ---------------------Test pfSense box----------------------test clients  (172.31.125.0/24
                                                                  l
                                                                  l
                                                                  l
                               LAN Port-192.168.15.0/24 ------------     Used as maintenance port.

    When its "Offline" updates nor packages show up...


  • Some more-  Update…

    I noted last week that I could not set the bridge interface to DHCP and get it to obtain an address.  The work done on http://redmine.pfsense.org/issues/2314 seems to have fixed that. I now get an address.

    The bridge gateway problem still exists however.

    If I revert to 2.0.1 this works fine.


  • I blew this box up again and loaded 2.0.1 and upgraded to the last 2.1 snap of Friday May 18…

    The gateway is now coming up fine...    So possibly good since issue 2314 was fixed and just took a rebuild on my end...

    :)