Unbound 1.4.14_01 with 2.1-dev snapshot - not working


  • LAYER 8 Global Moderator

    So had some issue trying to upgrade to 2.1-dev snapshot.  Ended up having to do a clean install.

    Trying to get my system back to how I like it, a required package is unbound.  But does not seem to want to get going.

    Get this error when trying to create ACL

    Fatal error: Call to undefined function unbound_get_next_id() in /usr/local/www/unbound_acls.php on line 61

    unbound will not start.  Going to try reinstall of the package.. I thought it was suppose to create a default ACL?

    Well that did not work, tried reinstall.. Tried starting without ACL… get this error whenever try to start it

    php: /pkg_edit.php: The command '/usr/local/sbin/unbound-control start' returned exit code '127', the output was '/usr/local/sbin/unbound-control: not found'

    here is current snapshot running
    2.1-DEVELOPMENT (i386)
    built on Mon Feb 27 20:59:13 CET 2012
    FreeBSD 8.3-PRERELEASE



  • I need to test this - will see if I can get to this sometime this weekend.



  • I'm having a similar issue, running a dev build of pfSense, Unbound is running but getting the following error when trying to setup an ACL:

    Fatal error: Call to undefined function unbound_get_next_id() in /usr/local/www/unbound_acls.php on line 61

    Need any logs etc posted up?



  • ok ok, it wont work since 2.1 has the start of unbound been integrated into the base. I did start to work on the package to allow it run along side it but figured I am just waisting my time and that it would be best to spend my time the actual unbound integration. I guess i best start moving on it so that we can at least start getting that tested.


  • LAYER 8 Global Moderator

    So why would you start it's integration and leave it in a unworking state?

    So your saying that can not use unbound if using one of the 2.1 snaps?  Or is there some other way to get it to work since its being integrated?

    Really missing my unbound - Please Fix! ;)



  • Well its not in a 'unworking state', it is just that the webGUI hasn't been exposed yet.


  • LAYER 8 Global Moderator

    So your saying its already installed and I don't need to install the package?  I don't see it listed as service to start, etc.

    So how do I get it running on 2.1 snapshot?


Log in to reply