Network discovery not working with pfsense



  • I have been struggling to get network discovery to work correctly with windows 7. I have tweaked the settings under the dns forwarder and I can now use the names to access what I need. I have also set up a samba server on a different linux server and still have the same problem. As soon as I route my internet through only the dsl router everything works fine. Any solutions?



  • @joelwhrs:

    I have been struggling to get network discovery to work correctly with windows 7. I have tweaked the settings under the dns forwarder and I can now use the names to access what I need. I have also set up a samba server on a different linux server and still have the same problem.

    The systems are on different IP subnets?

    Please give more details on the way in which network discovery is not working correctly: I do … and I see ... but I expected to see  ...

    @joelwhrs:

    As soon as I route my internet through only the dsl router everything works fine. Any solutions?

    The systems are now on the same IP subnet? If not, what is is the difference in the two configurations?



  • All the systems are on the same IP subnet. If I click on network on windows 7 it will only show the laptop that I am using. What I want to see is a list of all the devices on the network with sharing capabilities, etc. What I mean by routing it through the router only is I disconnect the pfsense box which is bridged to a dsl modem and connect a different modem/router and everything works with it. I have just noticed now that randomly if the laptop is idle for a long enough time the other devices will show up.



  • Does anyone have any ideas on this? I have a few customers that want this system setup for them and I do not want to do it without network discovery working correctly.


Log in to reply