DNS issues with Kindle Fire



  • Hello All,

    Prior to all changes, the Fire worked.
    I recently installed a pfSense box as a replacement to a DD-WRT box as the main router/dhcp/dns for my house. I have two DD-WRT boxes setup as wireless APs. The APs are set to forward DHCP request and work just fine. I have other wireless clients, laptop, cell phone, etc. and they all connect to the wifi, receive the proper DHCP info and connect to the internet just fine.

    However, I have been running into trouble with a Kindle Fire. I have traced the issue to the pfSense and am not sure what to do now. I ran a packet capture and I can see traffic from the Kindle going to the pfSense on port 53, but no return traffic.

    I have tried with both DNS forwarder on and off. No return traffic is passed. I have also tried setting a static IP/DNS/Gateway on the Kindle, and no luck.

    Current packages:
    bandwidthd  -  HAVP antivirus  -  squid  -  Lightsquid

    I am unsure of what to try next so I was hoping I could get some light shed on this issue and what I could do to resolve it.

    Thanks to all who help!



  • Do you have a firewall rule allowing at least DNS access on the pfSense interface that the Kindle connects to?



  • I have 3 internal interface on the pfSense. All 3 are bridged together, the DHCP runs on this bridge. I copied over the default rules to the LAN1-3 interfaces and the Bridge interface.

    These rules are the Anti-lockout rule on LAN 1 and the Default allow LAN to any rule is on all interfaces.

    edit:
    Ah, it has been solved. The allow LAN to any rule was not on my Bridge interface. Sometimes it helps to have a second set of eyes. Thanks.


Log in to reply