Pfflowd not starting automatically on 2.1-DEVELOPMENT (amd64)



  • Hello,

    Hopefully this will help someone else if they are having problems with pfflowd not starting.

    I installed the pfflowd package on my fresh 2.1-DEV install, and couldn't get it to start.  I was able to start it manually by just running '/usr/local/sbin/pfflowd -n 172.22.22.22:12345 -S any -v 5' but starting it from Status -> Services menu wouldn't work.

    I took a look at the /usr/local/etc/rc.d/pfflowd.sh script and it has automatically configured the start block as:

    rc_start() {

    /sbin/ifconfig pfsync0 up
    /usr/local/sbin/pfflowd  -n 172.22.22.22:12345 -s 172.22.22.254 -S any -v 5
    }

    172.22.22.22 is my collector and 172.22.22.254 is pfsense.

    If i try to run that pfflowd line manually it doesn't like the -s switch:

    pfflowd: illegal option – s
    Invalid commandline option.
    Usage: pfflowd [options] [bpf_program]
      -i interface    Specify interface to listen on (default pfsync0)
      -n host:port    Send NetFlow datagrams to host on port (mandatory)
      -r pcap_file    Specify packet capture file to read
      -S direction    Generation flows for "in" or "out" bound states (default any)
      -d              Don't daemonise
      -D              Debug mode: don't daemonise + verbosity
      -v              NetFlow export packet version (default 5)
      -h              Display this help

    if i remove '-s 172.22.22.254' it starts fine until i make a change in the interface and the pfflowd.sh script is regenerated with the -s switch.


  • Rebel Alliance Developer Netgate

    Try it again, the PBI is 0.8 now.


Log in to reply