Installing pfsense 2.0.1 on USB Flash Drive

  • Possible?
    I am trying to migrate my harddisk setup to the USB Flash Drive I just bought in order to free up that disk.
    With harddisk the router runs perfectly smooth without any issues on booting.

    Moving on to the USB,
    It is a Chinese brand, 4GB SLC thumb drive.
    When trying to boot it as nanoBSD, no matter 2GB nor 4GB version, it just keeps saying geometry mismatch…..any idea for how it can be solved?
    I low-level formatted it like 30 times for trying different images and as a torture test........looks the drive is free from defects.

    Thanks for the attention.

    PS : I have also tried the 3rd option of the menu, boot from portable device and it works.
    How can I just switch to it as the default? I have to make sure it can reboot blindly.

  • Solved by adding the tricks….......
    It would be nice if this is by default on, it doesn't really cause much extra time from booting but a few hours for ignorance like me to trouble-shoot ::)

Log in to reply