{possible BUG] ECN is disabled, so altq can't use it?



  • Was testing ECN, and couldn't get it to work for any of the systems on my network to the outside world, then while researching the issue, I looked at net.inet.tcp.ecn.enable and saw it was set to 0.

    As soon as I set it to 1, my tests started working…. if it is being used by the GUI interface, shouldn't this be set to true by default, or am I unnecessarily setting something I shouldn't?



  • Based on some quick grep, the net.inet.tcp.ecn.enable sysctl tunable doesn't seem to be reference anywhere in the webGUI code.



  • It depends on the needs actually.
    It only affects local originated traffic so….



  • well, ever since I enabled the flag, ECN tests work.  Without this set, even with ECN enabled in traffic shaper, ECN tests fail.  Perhaps it should be force set if enabled in traffic shaper.


Log in to reply