PfSense 2.0 IPSec LAN to LAN with Cisco PIX running 6.3



  • I am currently trying to work out an IPSec VPN tunnel between a pfSense box and a pix 501.  From what I can tell the tunnel is up but I am not able to ping from LAN to LAN.

    Here is the topology:

    Here is the PIX config:

     PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 2KFQnbNIdI.2KYOU encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname MCC-PIXHOME-01
    domain-name mcc.local
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list PFSVPN permit ip 192.168.200.0 255.255.255.0 172.31.203.0 255.255.255.0
    access-list PFSVPN permit ip 172.31.203.0 255.255.255.0 192.168.200.0 255.255.255.0
    access-list nonat permit ip 172.31.203.0 255.255.255.0 192.168.200.0 255.255.255.0
    access-list nonat permit ip 172.31.203.0 255.255.255.0 10.0.0.0 255.255.252.0
    access-list nonat permit ip 192.168.200.0 255.255.255.0 172.31.203.0 255.255.255.0
    access-list nonat permit ip 10.0.0.0 255.255.252.0 172.31.203.0 255.255.255.0
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute
    ip address inside 172.31.203.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool homepool 172.31.204.1-172.31.204.254
    pdm location 172.31.203.200 255.255.255.255 inside
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list nonat
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec security-association lifetime seconds 86400 kilobytes 50000
    crypto map dyn-map 10 ipsec-isakmp
    crypto map dyn-map 10 match address PFSVPN
    crypto map dyn-map 10 set pfs group2
    crypto map dyn-map 10 set peer 1.1.1.1
    crypto map dyn-map 10 set transform-set ESP-AES-128-SHA
    crypto map dyn-map 10 set security-association lifetime seconds 86400 kilobytes 4608000
    crypto map dyn-map interface outside
    isakmp enable outside
    isakmp key ******** address 1.1.1.1 netmask 255.255.255.255 no-xauth no-config-mode
    isakmp nat-traversal 20
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption 3des
    isakmp policy 1 hash sha
    isakmp policy 1 group 2
    isakmp policy 1 lifetime 28800
    isakmp policy 10 authentication rsa-sig
    isakmp policy 10 encryption des
    isakmp policy 10 hash sha
    isakmp policy 10 group 1
    isakmp policy 10 lifetime 86400
    management-access inside
    console timeout 0
    terminal width 80
    Cryptochecksum:2ddb78756f3b0373eb0da5a37d49f731
    : end
    PIX# 
    

    Here is the IPSec config on the pfSense box:

    Phase 1:

    Phase 2:

    What I would like to be able to do:

    Ping from 10.0.0.0/22 to 172.31.203.0/24
    Ping from 172.31.203.0/24 to 10.0.0.0/22

    Please help!!!  ???



  • Did you add the rules in the firewall tab on the IPSEC interface ?


Log in to reply