HTTP_REFERER on index.php after upgrade



  • I had a system running 2.0 RC3-amd64, and after auto-upgrading to 2.0.1 I noticed it had upgraded to i386. I manually "upgraded" to 2.0.1-amd64 and everything went fine (after the manual reboot) and all services are up with no problems, except now whenever I hit the pfsense logo to get back to the main page, I get the message:

    An HTTP_REFERER was detected other than what is defined in System -> Advanced (http://172.16.0.1/system_firmware.php). You can disable this check if needed in System -> Advanced -> Admin.

    I already tried disabling the check but I get the same message. Is this maybe due to a leftover file from the platform conversion?


  • Rebel Alliance Developer Netgate

    If that check is disabled it shouldn't be able to hit that error at all. It's possible that something went wonky when crossing architectures, but I haven't seen that before.

    If you can't get past it, you can disable sending the referer in your browser (easy to do with Opera, not sure on the others offhand, it's probably in about:config on ff) and then get in that way to fix it.



  • Actually this just happens when I hit index.php directly (as when clicking the pfsense logo). If I just hit the IP address on the URL bar, it goes in fine and I can go into any menu I need, so at this point, this error is only a minor "annoyance" when navigating the system as clicking the pfsense logo to go to the dash is something I use often.


  • Rebel Alliance Developer Netgate

    Sure it's not something cached by your browser? Chrome is really bad about that



  • jimp, yes that was the problem… I tried with Firefox and no problem. Then I tried Chrome in incognito mode so it doesn't use previous caches and it works too... Thanks!


Log in to reply