Multi-wan load balancing does not load balance



  • I just can't figure out why it isn't working. Here's my setup:

    Satellite Modem ====>
                                        > pfSense ====> LAN
    Satellite Modem ====> /

    pfSense 2.0.1 is running on a virtualbox on my laptop with three NICs. One each for the WANs, one for the LAN. Status > Interfaces shows all three working, LAN clients can pull an address via DHCP. Status > Gateways shows WAN1 and WAN2 online. In System > Gateways > Groups I have created a group with both WANs, both Tier 1, called Balancer. In Firewall > Rules under LAN I have the LAN net set to the Balancer gateway group. Neither WAN1 nor WAN2 are defined as the default gateway.

    The problem is that about 95% of traffic is on WAN1. I can see real meaningful traffic on WAN2 via Darkstat, as well as Status > Traffic Graph. But it's a very small amount, while WAN1 is usually at max capacity.

    As an experiment, I changed WAN1 to Tier 2 in the Balancer group I created. This resulted in no change whatsoever; 95% of traffic remains on WAN1.

    Any ideas? Did I miss anything? I'm pretty new to this actually…



  • you need to set the Gateway Group as Gateway in your firewall rules on LAN interface.
    Further your WAN1 and WAN2 must not have the same Gateway from your ISP!



  • You also need to have both WANs in Tier 1 in order to round robin between them.

    Best

    Kostas



  • As I stated, I do have the gateway group set as the gateway in firewall rules for LAN interface. Each WAN does have a unique gateway from the ISP.

    I only changed WAN1 to Tier 2 as an experiment. The strange thing, with that setting, WAN2 should get all the traffic, right? But it does not. It doesn't make any difference at all.



  • Have you rebooted firewall after that change or deleted old tcp sessions?



  • I have tried rebooting the firewall.



  • Using squid and Multi-WAN on the same machine needs additional configuration.



  • @Nachtfalke:

    Using squid and Multi-WAN on the same machine needs additional configuration.

    Aha. I will search the forums for such configuration. Thank you.


Log in to reply