NTOP (RRDtool) shows non ANSI charachters



  • Version: 2.1-DEVELOPMENT (i386) built on Wed Mar 7 22:07:07 CET 2012 FreeBSD 8.3-RC1

    Trying NTOP, works nice with 2.1, well almost.
    Going to:
    |>Summary > Traffic >

    I see this (see picture).
    It seems that somewhere a wrong language is been set, non western ASCII/ANSI (?) character set. Is this new for 2.1?
    And someone knows where i can look at to correct it?

    edit: i see it's a part of 'RRDtool'

    edit2: seems to be missing fonts for RRDtool

    edit3: indeed fonts are missing, found the font 'DejaVuSansMono-Roman.ttf' used by 'RRDtool', but as unfamiliar i am with 'RRDtool', cant find the config file, so tried to change the symlink, with no good luck.

    [2.1-DEVELOPMENT][admin@pfsense.localdomain]/usr/pbi/rrdtool-i386/etc(130): ls -al
    lrwxr-xr-x   1 root  wheel   20 Mar 10 22:58 fonts -> /usr/local/etc/fonts

    [2.1-DEVELOPMENT][admin@pfsense.localdomain]/usr/pbi/rrdtool-i386/etc(131): cd fonts
    fonts: No such file or directory.

    [2.1-DEVELOPMENT][admin@pfsense.localdomain]/usr/pbi/rrdtool-i386/etc(155): rm fonts/
    [2.1-DEVELOPMENT][admin@pfsense.localdomain]/usr/pbi/rrdtool-i386/etc(156): ln -s /usr/local/share/rrdtool/fonts  /usr/pbi/rrdtool-i386/etc/fonts

    edit4: i am stuck.



  • Noticed the following, didn't see last-night. When i go, it all looks good.

    |> Status > RRD Graphs



  • Yeah, that is a ntop issue. The rrd graphs have been working ok on 2.1 for a while now.


  • Rebel Alliance Developer Netgate

    That's probably because the newer rrdtool is being included in the 2.1 PBI… on the old build setup, it was pulling in rrdtool 1.2.x because we forced it that way. PBIs are a bit fancier than that. Not sure what other build options we might need to pass to ntop to fix this though.



  • Possibly related, uninstalling ntop seemed to uninstall rrdtool, breaking the RRDGraphs.

    an update to the latest snapshot fixed it, of course.


Log in to reply