Shuttle Barebone XG41 pfsense ?



  • Hello and good day.
    I just have a question':
    Shuttle Barebone XG41 that seems like a really nice pfsenes router?
    And do it have good hardware?
    It have 2 nic so it is perfect.
    Kind regards.
    And i am from norway. So any one in norwegian :)?



  • Måtte bare si hei til en annen nordmann!

    Came here while searching for the answer of that exact question. Some time have passed since you made the post. Did you end up buying it, did it work? Actually there are a lot of pages with the exact question for the shuttle around on the web. Several people with the same setup ask for input on their system and if it is compatible. But NO clear answer sadly. I will probably buy and try it out. Just need to find someone still selling lga775 cpus



  • Tried my XG41 with pfsense but it didn't work that great because of the integrated realtek network cards.
    I got a lot of timeouts and often lost connection to the internet.


  • Netgate Administrator

    Did you try a 2.1 snapshot? It would have better driver support for those NICs.

    Steve



  • I have been using a XG41 for half a year now both on 2.0.1 and lately the 2.1 (due to my IPv6 experimentation) and it has worked OK.

    Please see my posts in the following thread:
    http://forum.pfsense.org/index.php/topic,41742.0.html
    and onward

    See especially the following post.
    http://forum.pfsense.org/index.php/topic,41742.msg217644.html#msg217644

    Some people had problems with certain MAC revisions of 8111E chipset but I managed to get Shuttle techies to test
    and they included the screenshots that these chipset in the XG41 was safe for FreeBSD 8.1.

    The one not working was "re0: Chip rev. 0x2c800000"
    XG41 is (at least in mine) reporting "re0: Chip rev. 0x2c000000" which should work.

    And I have not experienced any timeouts or connection-loss.

    When I last rebooted my XG41 after upgrade to 2.1 it had an up-time of 114 days.

    Best regards
    Dan Lundqvist
    Stockholm, Sweden.


Log in to reply