Asterisk 1.8 package



  • @m4f1050:

    Any idea when these will be out of beta stage and available via the package section in the webgui?  (asterisk 1.8.x and the asterisk-gui 2.x)
    I am currently on 2.0.2

    Thanks.

    Mafioso,

    The port submit of asterisk-gui is still pending on freebsd ports.  :(



  • Good luck and I hope they hurry up because I am not installing Asterisk until the gui is there or altogether.  :)



  • Ditto. I am totally confused with the current package and how to configure it. I am a GUI guy and would love to have GUI for this package for me to start taking advantage of it.



  • Hello,
    a newbie question…

    I'm yet another cheapskate with a TDM400P PCI analog telephony card doing 'nowt in an old box...and wondering if the zaptel/DHADI route (even with the apparent echo issues...) is worth pursuing and how to get some stable drivers to try on a production box (I know!!).

    I've been looking around
    http://www.voip-info.org/wiki/view/FreeBSD zaptel looked interesting but seems a dead end...

    The card is recognised by pciconf -lv  :
    none2@pci0:1:8:0:      class=0x078000 card=0x0003b100 chip=0x0001e159 rev=0x00 hdr=0x00
        vendor    = 'Tiger Jet Network Inc'
        device    = 'Multiple devices use this ID: General Purpose I/O Controller'
        class      = simple comms

    but doesn't show up in dmesg

    Is there hope? or is it (very likely) easier to erm... Ubuntu it?

    Any pointers very welcome  ;D



  • To run asterisk cards on freebsd will need it drivers and dahdi. I do not recomend it on pfsense.



  • @marcelloc:

    To run asterisk cards on freebsd will need it drivers and dahdi. I do not recomend it on pfsense.

    marcelloc
    Thanks - I had to ask the question…  there seems to have been some activity - but quite a while ago and the hardware has moved on.

    I guess I'll try a Draytech VoIP router to handle analog and see how I get on with that....  TDM400P >=ebay



  • Have a little question that may become big.

    I'm running pfSense 2.1 beta1 and installed Asterisk package.

    I can see the Asterisk page in the status menu and the service running in the services status page. So I'm assuming that the package is working, at least for now.

    But in the main Asterisk page it enumerates these directories:

    • Directories
        –-----------
        Configuration file:         
        Configuration directory:    /usr/pbi/asterisk-i386/etc/asterisk
        Module directory:            /usr/pbi/asterisk-i386/lib/asterisk/modules
        Spool directory:            /usr/pbi/asterisk-i386/var/spool/asterisk
        Log directory:              /usr/pbi/asterisk-i386/var/log/asterisk
        Run/Sockets directory:      /usr/pbi/asterisk-i386/var/run/asterisk
        PID file:                    /usr/pbi/asterisk-i386/var/run/asterisk/asterisk.pid
        VarLib directory:            /usr/pbi/asterisk-i386/share/asterisk
        Data directory:              /usr/pbi/asterisk-i386/share/asterisk
        ASTDB:                      /usr/pbi/asterisk-i386/var/db/asterisk/astdb
        IAX2 Keys directory:        /usr/pbi/asterisk-i386/share/asterisk/keys
        AGI Scripts directory:      /usr/pbi/asterisk-i386/share/asterisk/agi-bin

    Are they alright or I have to move them to another place before configuring Asterisk?

    I think that they should be pointing to other places.



  • @muchacha_grande:

    Are they alright or I have to move them to another place before configuring Asterisk?

    Yes, pfsense 2.1 installs packages under /usr/pbi



  • Hi, I've recently installed Asterisk package on pfSense 2.1 beta1 and made it work with a little config.
    But I can't see logs or calls on the status interface. May be is not correctly installed.

    Thank you…



  • I did not checked asterisk package on 2.1.

    Maybe it's looking for logs on the wrong folder.

    check if there are logs in /usr/pbi/asterisk-xx/var folder



  • Yes, they are there…

    More precisely in /usr/pbi/asterisk-i386/var/log/asterisk/



  • @muchacha_grande:

    Yes, they are there…

    More precisely in /usr/pbi/asterisk-i386/var/log/asterisk/

    try to create a symlink to /var/log/asterisk



  • I'd modified the paths of the PHPs. They are hardcoded for version 2.0.

    Thank you very much…



  • Hi again,

    finally with an Asterisk up and running on pfSense 2.1 beta1.

    I'm trying to enable fax sending and receiving with res_fax.so and res_fax_digium.so.

    I've already registered my box with Digium's register method explained in Digiums site but theres a lib missing when I do module load res_fax_digium.so.

    Here is the output:

    Asterisk 1.8.19.0, Copyright (C) 1999 - 2012 Digium, Inc. and others.
    Created by Mark Spencer markster@digium.comAsterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
    This is free software, with components licensed under the GNU General Public
    License version 2 and other licenses; you are welcome to redistribute it under
    certain conditions. Type 'core show license' for details.

    == Parsing '/usr/pbi/asterisk-i386/etc/asterisk/asterisk.conf':  == Found
      == Parsing '/usr/pbi/asterisk-i386/etc/asterisk/extconfig.conf':  == Found
    Connected to Asterisk 1.8.19.0 currently running on pfsense (pid = 6011)
    Verbosity is at least 3
    pfsenseCLI> module load res_fax_digium.so                                                                                Unable to load module res_fax_digium.so
    Command 'module load res_fax_digium.so' failed.
    [Feb  7 21:26:58] WARNING[6011]: loader.c:409 load_dynamic_module: Error loading module 'res_fax_digium.so': Shared object "libc.so.6" not found, required by "res_fax_digium.so"
    [Feb  7 21:26:58] WARNING[6011]: loader.c:874 load_resource: Module 'res_fax_digium.so' could not be loaded.
    pfsense
    CLI>

    There in no comments about this at Digium's site.

    Does anyone succeded on making fax module work on pfSense?

    Thanks…/markster@digium.com



  • Hello,
    I'm testing asterisk on pfsense since some weeks. It's very stable :)
    Thank you for this great work !

    I have 3 pfsense with an IPSEC vpn :
    site A : 192.168.1.0
    site B : 192.168.2.0 - with an pika warp / freepbx asterisk
    site C : 192.168.3.0 - with your package asterisk on pfsense.

    I would like to connect from site A to site C with a SIP client. Test with zoiper.

    zoiper site A to asterisk site B : ok. it works :)
    zoiper site A to asterisk pfsense site C : ko. it doesn't works :(

    On states pfsense, of the site A & C, i have :
    NO_TRAFFIC:SINGLE

    IPSEC VPN rules are corrects. * for all settings.
    what should i do ?
    thank you :)



  • I see the asterisk gui, but the user and password do not work, edit manager.conf and nothing



  • I see that the GUI of the package needs some work to be compatible to 2.1. I'll soon post the necessary modifications.



  • Is there a place where I could push the modifications needed for this plugin to work with 2.1? Like GitGub, etc…?



  • I've just modified my config file editor page, with complete backup and restore options.

    I've also optimized the installation to properly run on NanoBSD systems. I'm going to update them accordingly at https://github.com/pfsense/pfsense-packages/tree/master/config/asterisk




  • Hi,

    this post refer to i thread i started because this the GUI was not working properly on PfSense 2.1 release
    http://forum.pfsense.org/index.php?topic=66660.0

    i find out at the moment that two file of the GUI need to be modified to point to the new location for the package:

    asterisk_calls.php
    path need to be modified to :
    "/usr/pbi/asterisk-amd64/var/log/asterisk/cdr-csv/Master.csv"
    or
    "/usr/pbi/asterisk-i386/var/log/asterisk/cdr-csv/Master.csv"
    depending of architecture instead of :
    "/var/log/asterisk/cdr-csv/Master.csv"

    asterisk_log.php
    path need to be modified to :
    "/usr/pbi/asterisk-amd64/var/log/asterisk/messages"
    or
    "/usr/pbi/asterisk-i386/var/log/asterisk/messages"
    depending of architecture instead of :
    "/var/log/asterisk/messages"

    for edit config file, the new path is "/usr/pbi/asterisk-amd64/etc/asterisk" for the config file

    i don't know where to go to do the modification or if someone have to do it at my place (never did it before) but this make the package working on PfSense 2.1 . It is working flawlessly for me for the moment but i have to mod the php file each time an update is done on the package.



  • Work is in progress just now with modifications to address these issues.

    Actually paths will be corrected on the file system to point to writable locations (as /usr/pbi/…. is not writable on NanoBSD), symlinks will be used and Asterisk configuration files will be updated accordingly on first install.

    Please be patient, soon the update will be available in the packages list.



  • Package update v0.3 should be online soon.

    If you already installed asterisk package on v2.1, I suggest to start from scratch by creating a fresh install of pfSense, or at least uninstall the complete Asterisk package, remove these directories by hand, reboot and reinstall Asterisk package:

    Spool directory:             /var/spool/asterisk
    Log directory:               /var/log/asterisk
    Run/Sockets directory:       /var/run/asterisk
    ASTDB:                       /var/db/asterisk/astdb
    


  • Note to users upgrading from pfSense v2.0.x:

    Asterisk package was converted to PBI, thus the system file locations for it have been changed. That means that the asterisk.conf file on the 2.0.x and 2.1 will have different [directories] sections. Please revise the directory paths on the fresh install of Asterisk on v2.1, and correct them manually before restoring the configuration from 2.0.x.

    On simpler scenarios, where only SIP protocol is used, the first approach to upgrade Asterisk would be to actually install it fresh on a v2.1 box, and replace sip.conf and extensions.conf files with the previous ones. All the other config files can be left in their default state if you didn't modify them earlier.



  • @robi:

    Work is in progress just now with modifications to address these issues.

    Actually paths will be corrected on the file system to point to writable locations (as /usr/pbi/…. is not writable on NanoBSD), symlinks will be used and Asterisk configuration files will be updated accordingly on first install.

    Please be patient, soon the update will be available in the packages list.

    Thanks robi for the quick answer :)

    @robi:

    Package update v0.3 should be online soon.

    If you already installed asterisk package on v2.1, I suggest to start from scratch by creating a fresh install of pfSense, or at least uninstall the complete Asterisk package, remove these directories by hand, reboot and reinstall Asterisk package:

    Spool directory:             /var/spool/asterisk
    Log directory:               /var/log/asterisk
    Run/Sockets directory:       /var/run/asterisk
    ASTDB:                       /var/db/asterisk/astdb
    

    i'll have to reinstall my setup from scratch on 2.1 cause my HDD is failing

    if i have little time, i'll post the name of the file and what to temporary modify as a workaround until the package is completely updated.

    you do a great job here folks :)

    thanks



  • It's already done, devs from pfSense need to pull it in to the servers…



  • @robi:

    It's already done, devs from pfSense need to pull it in to the servers…

    awsome !!

    i'll wait and test it :)

    thanks



  • is the last update Asterisk 1.8 pkg v0.3 broken for you ?

    • does'nt want to start via web GUI (via status -> service or via Asterisk command page).
    • asterisk log page is broken (parse error)
    • it start manually but extension won't register (no modification in conf file from 1.8 pkg v0.2)

    EDIT :
    nevermind for extension not registering

    BUT
    still need to start manually via shell ( asterisk -C /usr/pbi/asterisk-amd64/etc/asterisk/asterisk.conf )

    and log page is missing a ")" on line 70



  • Yes, I've fixed them yesterday evening, pushed them to the server, still waiting to be pulled in.



  • Hi roby,

    I've tested it on 2.1 and code was not working correctly.

    I did some changes and at least on 2.1 it's working fine now.

    Check if it's ok on nanobsd too.



  • It's broken again, sent you a PM with the reason why.



  • @robi:

    It's broken again, sent you a PM with the reason why.

    Can you check again with latest changes?



  • The Asterisk package works now with pfSense 2.1. both full setup and NanoBSD.

    It includes a web interface for issuing basic or custom commands to asterisk console, calls log, system log, configuration files editing option, configuration directory backup and restore option.

    By default when installed on pfSense it's preconfigured for SIP operation, and has got two demo extensions, 301 and 302 which allow testing with real IP phones or softphones through the LAN interface.



  • hello
    tell here how to install chan-dongle? https://code.google.com/p/asterisk-chan-dongle/ ?

    PF 2.1
    Asterisk Services 1.8 pkg v0.3.1 Asterisk is an open source framework for building communications applications.
    Asterisk turns an ordinary computer into a communications server.



  • You need to compile it on freebsd 8.3



  • How cool… One could use Asterisk to place directly mobile calls through a supported 3G modem.



  • @robi:

    How cool… One could use Asterisk to place directly mobile calls through a supported 3G modem.

    Yes. I've tested it on linux and it works. The problem I had way with usb power supply for multiple 3g modem and power boot sequence some times.



  • Hi Marcelloc,

    First, thanks for your great work again…
    I was running a FreePBX server behind Pfsense, however it seems there are some NAT problem and I can't find any solution for that.
    Then I tried your Asterisk package, it works perfect  :D. The only question is it's difficult for me to edit the configurations... :-[
    I read your post and you have installed Asterisk-gui successful before, I am now sure it's still working for latest pfsense 2.1?
    Can I ask you to post a guide here?

    Thanks



  • I've not tested it on 2.1 yet and freebsd port is still pending.



  • @zlyzwy:

    Hi Marcelloc,

    First, thanks for your great work again…

    It's mainly a robi work. I just did some small modifications  ;)



  • @zlyzwy:

    The only question is it's difficult for me to edit the configurations… :-[
    [/quote]

    if it is only to modify the config file directly, you can do it this way (if you use windows) :

    • enable SSH in "System" -> "Advanced" - > "Admin Access" and check "Enable Secure Shell"
    • use WINCSP to access the files in /conf/asterisk/

    that's the way i modify my conf files for asterisk.

    I hope the GUI will be ported soon. :) Will be good to have a complete GUI to manage configuration.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy