CF Card issues **hw.ata.ata_dma=0**



  • I cannot successfully add the lines (hw.ata.ata_dma=0) to /boot/loader.conf or /boot/loader.conf.local and boot the iso after making the change. I have tried winiso and magiciso.

    Once I burn the modifed iso it boots but then claims it cannot load kernel.

    Help!!



  • Something is confusing me a bit here: In your topic you say something about a cf-card but then you mention an ISO? The ISO is meant for botting off from a cdrom. We have special embedded images that are meant to be used with cf-cards. Please clarify what exactly you want to do and how you currently try to do it.



  • Sorry this may clear it up.

    I have tried the embedded and cannot get it to boot up. The monitor seems to hang and i DO NOT get the / showing on the monitor just BIOS info. I cannot terminal in using a null cable modem.

    So i have tried the live cd and wanted to install the full version from there onto the CF. I was getting a problem with "error issuing READ_DMA command" sooo I booted with the live cd and hit 6 which allowed me to echo hw.ata.ata_dma=0 to /boot/defaults/loader.conf with success.

    I now have the Live version installed and booting up on the CF…..but I am now having a problem with the nics not being detected.

    Realtek 8110sc ???

    I would like to use the embedded image but was having trouble editing the img file to add "hw.ata.ata_dma=0"



  • Embedded images work only on serial.



  • Hello!

    Are you using the embedded image at:

    http://snapshots.pfsense.com/FreeBSD6/RELENG_1_2/embedded

    or the LiveCD image at:

    http://snapshots.pfsense.com/FreeBSD6/RELENG_1_2/iso ?

    The embedded image does'nt not support keyboard+monitor.

    Embedded image can be mounted with full access. ISO images are for CD-ROM, so you can mount only in read only mode.

    If you want an embedded pfSense system working with keyboard+monitor yo should try the non-official images at hacom.net:

    http://shopping.hacom.net/catalog/pub/pfsense

    Regards,

    Josep Pujadas



  • I will make the change it the img. "hw.ata.ata_dma=0"

    Thanks Guys.


Log in to reply