IPSec tunnel up but can’t access networks other then routers SOLVED



  • I have just installed pfsense to replace an old D-link VPN router in a LAN to LAN VPN using IPSec.
    The IPSec tunnel is up and I can from the client access pfsense webconfig thru the tunnel and ping it, but I can’t ping the server or use RDP.

    At the local office we have the pfsense with a public fixed ip and a server behind that router on the LAN if.

    At the remote office we have a D-Link DFL-700 VPN router and a computer trying to access the server but can’t. This router uses DDNS as it has a dynamic public IP.

    Both the server and the client has manually added routing.
    There is no firewall active on the server and at the router all traffic is allowed on both the LAN if and IPSec IF.
    I have more or less just copied the settings from the old D-link router to pfsense so all networks should be correct and routing on the computer worked before.
    At the server side (pfsense) we have 192.168.1.0/24 as network and at remote side we have 192.168.2.0/24

    I think it is a small setting somewhere I have missed, as it almost works, this is the first IPSec setup I do on pfsense, does anyone have any idea what’s wrong?



  • Solved it by adding a Virtual IP (Proxy ARP) in pfsense on the LAN interface for the remote side network!


Log in to reply