Vmware two Nic ,can not port forwarding.



  • Envir:
    Host machine:AMD athlon 64X2 4800+ 2.51G
                      RAM:2G
    Vmware:workstation 8.0.1 build-52899
    Cause:
            Host machine can not installed with PFsense2.0.1–-AMD.Maybe motherbord not support on PF.
    then i try to install Vmware to instead of Host macine feature.
            when have installed it and configure two Nic for VM box.
    em0 for LAN bridge,for transfor data with internal LAN.
    em1 for WAN bridge,for tansfor data with Internet

    ISP give xxx.xxx.xxx.32/29.
    I use switch divided into 2 lines .one for product router,and one for Vm box Internet NIC.

    default setting environment,client in LAN could go internet via our vm pfsense box.

    but i can not publish LAN Service to Internet with PFsense port forwarding feature.

    please give me hand on this issue!!!!!

    Btw:
    I try to use another testing environment ,it is ok.
    VMware use Two nic, one NAT ,one Host .
    NAT follow with product route gateway.
    and on VM system ,with XP system,created anther host box,Nic with Host mode.
    then,use This XP system with pfsense gateway.Everything is OK,
    include client go internet and other machine access behind pfsense machine some service with pfsense port forwarding feature.such publish XP 3389 with pfsense gateway.

    the above i find problem situation. i tcpdump some data and found some issue.
    VM box WAN Nic have received request,

    12:01:41.919632 IP xx.xx.xx.xx.51860 > yy.yy.yy.yy.ftp: Flags ~~, seq 2813601518, win 8192, options [mss 1440,nop,wscale 2,nop,nop,sackOK], length 0
    12:01:42.478126 IP yy.yy.yy.yy.8888 > xx.xx.xx.xx.51808: Flags [P.], ack 53, win 517, length 61

    For remote testing ,i created rule that allow internet users to  access 80 and 8888(ssh service) with rule,and there is ok.I can use outer internet right machine to  successful access them.

    Please give me some advise…

    s~~



  • have any like this issue.
    such as other vm box system.


Log in to reply