Ajuda Pfsense + OWA



  • Primeiramente quero agradecer ao fórum por muitas vezes que me ajudou, este é o meu primeiro tópico.
    Dei uma pesquisada no fórum e não achei nada a respeito, me desculpem se pesquisei errado e ja tenha algum tópico com o mesmo problema.

    Depois que instalei o Pfsense aqui na empresa eu não consigo mais acessar o endereço OWA internamente. Abri todas as portas necessárias e externamente eu acesso tranquilamente, porém internamente dentro da empresa eu só consigo acessar com o IP do servidor/owa, creio que seja erro de DNS, porque o DNS que direciona ip externos está na locaweb e funcionando, gostaria de saber como eu faço para configurar o DNS para acessar o serviço dentro da LAN com o mesmo endereço que eu uso pra acessar de fora, lembrando que antes do Pfsense eu acessava normal.

    Uso um IP estático embratel e um Dinâmico Virtua, sem Load Balance.

    não estou usando nenhum proxy ainda.

    Obrigado pela atenção de todos. ;D



  • O seu owa.meudominio.com.br aponta para a locaweb ou para seu ip externo?



  • o modo como acesso é assim… www.meudominio.com.br/correio... ele aponta pra locaweb e da locaweb vai para o meu ip da embratel com o endereço exchange.meudominio.com.br
    não manjo muito de DNS, desculpe se a resposta estiver errada, mas pelo pouco que eu entendo é isso.



  • rodrigonewmetal,

    Você pode usar o dnsforwarder do pfsense para acertar o dns com ip externo para o ip do seu owa.

    service -> dns forwarder -> host forwarder

    Já ia me esquecendo, bem vindo ao fórum.  :)



  • Ok Marcelloc, vou tentar.

    Muito obrigado pela ajuda!!



  • rodrigonewmetal,

    Se você tem owa na empresa então deve ter também um ad e ele deve ser o dns da sua rede.

    Neste caso você provavelmente vai precisar configurar o dns do ad também.

    se o meudominio.com.br não existe no seu ad, acredito que configurar a opção 'dns forwarder' no ad apontando para ao ip do pfsense resolva o problema.

    att,
    Marcello Coutinho



  • Ok, entendi oq vc quis dizer, no forwader do meu DNS no servidor do AD ja tem o IP do firewall , na verdade o mesmo IP que eu usava no roteador que eu tinha aqui, um Linksys que fazia LoadBalance.
    então só pode ser essa questão do forwader no Pfsense mesmo, vou dar mais uma estudada aqui na estrutura do DNS, obrigado pela força Marcello.



  • Então, eu desmarquei a opção "Allow DNS server list to be overridden by DHCP/PPP on WAN" habilitei o forwarder pro meu servidor DNS, mas mesmo assim nada… tem que dar um reset nele ou algo do tipo pra funcionar?



  • Eu consegui fazer o meu servidor DNS reconhecer o pfsense no dominio e reconhecer ele como forwader, porém ainda nada… tem alguma outra sugestão?



  • voce incluiu o host forwarder na configuração do pfsense?

    quando você resolve o nome do seu servidor de owa ele retorna o ip externo ou o que você configurou no pfsense?

    nslookup owa.meudominio.com



  • Obviamente que o seu servidor DNS (na estação em que está testando) deve ser o seu próprio pfSense (ao menos o servidor primário)… ;)



  • Bom dia, o servidor DNS Primário na minha estação está apontando para o Pfsense.

    Já o nslookup me volta

    Servidor: nome do meu servidor exchange
    Address: 192.168.1.100

    dns request timed out.

    está chegando ao servidor mas o dns ainda não está resolvendo… mas oq eu não entendo é pq ele resolve quando a solicitação é externa...  ???



  • Você criou regra de firewall na lan permitindo o servidor dns/ad/exchange acessar o dns do pfsense? O dns forwarder esta habilitado? Se você marcar na sua estação o ip do firewall como dns você consegue resolver nome?



  • Perdão Marcello, mas como eu faço para configurar essa regra? eu ja tenho ativado aquela regra que libera todas as portas para Lan… e o DNS Forwarder está ativado e está conectando com o servidor DNS do meu domínio.



  • A regra que libera tudo não é somente tcp?

    Já tentou marcar o dns da sua máquina com o ip do firewall?



  • A regra que libera tudo é any para todos os protocolos e any para todas as portas, ja tentei marcar o dns da minha máquina para o ip do pfsense, do servidor dns primário e para o ip da réplica de dns também… mas nada acontece... dns = demons name system... hahahaha.. ta complicado esse meu DNS



  • Entenda a ordem de precedência (prioridade) no pfSense quando de uma consulta DNS: http://forum.pfsense.org/index.php/topic,45406.msg237134.html#msg237134



  • Amigos depois de muito fuçar tendo a certeza que o problema não estava no meu DNS… descobri essa opção nas opções Avançadas - Firewall/Nat "Disable NAT Reflection for port forwards" desmarquei a caixa e foi como mágica... o OWA funcionou na hora!!!!  ;D

    Valeu pela Ajuda de vcs!!! qualquer coisa estou a disposição da comunidade para ajudar!!!


Log in to reply