(SOLVED) Portranges in Aliases not working ?



  • Hello @all

    i try to define an alias for Messenger Ports to get rid of Problems with my dual-wan setup. Therefore i inserted an alias and try to define the range (MSN) port 1863 - 1963 but it throws an error, im using the latest 1.01 snapshot

    Apr 26 13:42:02 	php: : New alert found: There were error(s) loading the rules: no IP address found for 1863:1963 /tmp/rules.debug:152: could not parse host specification pfctl: Syntax error in config file: pf rules not loaded The line in question reads [1963 /tmp/rules.debug]:
    

    Anyone have a hint ?

    Greetings
    Chris



  • Aliases do not support port ranges currently.



  • Can you give us an example of how you tried to set it up, just to prevent misunderstandings? a single IP alias in combination with a port range as portforward should work. Also please give more exact info about the version you are running (complete versiontag and buildtime please). The latest snapshots for example are tagged "1.2 beta 1 prerelease something" and not 1.0.1 something.



  • @hoba

    Hello, sorry a bit late but here is the info, im currently running:
    Version  1.0.1-SNAPSHOT-03-27-2007
    built on Sun Apr 8 18:53:20 EDT 2007

    I would like to insert an alias which defines the Portrange of MSN. The ports are from 1863 to 1963. So i only define PORTS within the alias and insert 1863:1963 in one single line. The colon should define this as a range from 1863 to 1963 as i read somewhere in the Help.

    Hope this is enough information !

    Greetings
    MBChris



  • Port ranges do work in the latest snapshots. Update to the 1.2 Beta and retry your test



  • Just tried that on my wrap with a recent version and it indeed seems to work, that was something new even for me  :D



  • if you're just on changing stuff with ranges… is there a chance to use port aliases in Advanced outbound NAT?
    (kinda annoying to define x rules if you just want to have 10~15 ports static)



  • @hoba:

    Just tried that on my wrap with a recent version and it indeed seems to work, that was something new even for me  :D

    Ok i will update my installation soon to 1.2 BETA

    Thank you anyway

    MBChris



  • Hi there, an update !

    I upgraded to

    1.2-BETA-1
    built on Mon Apr 30 10:51:10 EDT 2007

    But the problem still exists, if i insert 5000:5010 in one line under Aliases/Ports then i get the same error as stated in my first post

    Could i provide some more info to better inevestigate the problem ?

    Greetings
    MBChris



  • Ok, i solved the problem …

    I had to define another alias for a single port-RANGE.

    Mixed, eg. Ports: 5001,5002,5010:5100 does not work !
    for the Range i must define a new alias

    Anyway thanks for your help !

    MBChris
    (Marking thread as solved)


Log in to reply